glDrawTransformFeedback() fails on nVidia

When using DrawTransformFeedback on a GTX460 [Win7 64bit, OpenGL 3.3, latest release driver, up to the latest beta driver (260.93)] nothing is drawn but GL_INVALID_OPERATION is generated.
According to the spec GL_INVALID_OPERATION is only generated if EndTransformFeedback has not been called before, while the TFO was bound. But that’s what I actually do.

Unfortunately I don’t have another nVidia card to test the code, but on a Radeon 3850 it works as expected. So I assume that it is a driver-bug.
It may very well be the same problem as reported by MaB here: NVidia - transform feedback issue ???

I’d really like to submit a bug report, but from what I’ve found on nVidia’s webpage, the only way to do so is by registering as a developer. I tried to do so, but after submitting the application-form only a blank page was returned by the server. I sent an E-mail to afterward to ask if my application actually found its way into their system, so they could process it, but without luck. No response to my E-mail in over one week.
Is there any other way to submit a bug report?

Thanks for any advice.

Does this happen on the latest drivers? Can you share a small repro app?

It doesn’t work with the 260.99 drivers either.
I’ll try to put together a simple repro app over the coming weekend.

Well, I tried to create a test application exhibiting the behaviour I reported in my initial post.
But I’ve failed to achieve that, because the test application never failed.

Thus I turned the whole thing around and replaced the relevant code in my original program with the one from the working test application. And lo, it’s all working now. Unfortunately I can’t pinpoint what has changed, because basically it’s the same (albeit refactored) code.

So there is a good chance, that it was my code’s fault all along (and it shouldn’t have worked on AMD hardware at all), hence I feel sub-pixel small, want to apologise for any inconvenience and rest my case.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.