Hello everyone,

I have some OpenGL code calling glDrawRangeElements on a VBO (or a VA, makes no difference here, tried both ways) with some position, normal etc. data. This works fine on Win32 (didn’t try Linux), but seems to produce a segfault inside OpenGL on OS X.
Calling glDrawElements (the range actually included the whole array) works.
I tried it (after having fought my app-code for some time) on a peasant snippet having 4 vertices in a simple array and it failed just the same, bringing me to the conclusion that it’s no wrong index I pass to OpenGL…

Anyhow, has anyone a proof of glDrawRangeElements working under 10.3.4?

I’m running a 12" Rev A Powerbook (spring 2003) with a GF4 420 Go and, as mentioned, Panther 10.3.4.

If you happen to have the same machine available and have the spare time to hack and test this, you’d make me a smarter man :slight_smile:

If you don’t have the time, I could hack it myself for you to compile & run, although this could take several days, as the issue it quite low-prio atm and I’m a bit in trouble right now.

Big thanks,

Quake III probably doesn’t call it, so there’s little surprise if it’s broken… submit a bug report to Apple when you get the time.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.