"GL_Static_Draw" doesn't work


I use OpenGL via OpenTK and VBO to render a big shape of 100 000 Vertices With no texture. I only use 3 bytes color. I have very slow performence (25fps) !
When i call “glBufferData” i can use “GL_Static_Draw” or “GL_Stream_Draw” i have 25fps too.
I can use “DisplayList” instead “VBO” this change anything too.

2 500 000 vertices/second seem very slow (spec is 200 000 000).

Why the parameter “GL_Static_Draw” or “GL_Stream_Draw” doesn’t change anything ?

I Use Asus :

a7n8x-x with the last nforce2 drivers from Asus And the last BIOS.
A Aopen Aeolus GeForce FX 5700LE With the last driver for nvidia.
My CPU is a Athon XP 3000+
And my OS is Windows XP SP3
The AGP 8x is enabled in my BIOS

Use 4 byte color instead and take care of 16, 32 or 64 byte alignment of your vertex data; e.g., for position and color only use something like:

struct VertexData {
    Vector3f pos;    // 12 bytes
    Color4ub color;  //  4 bytes
};                   // 16 bytes

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.