I thought I’d have a play around with FBO’s. I downloaded the NVidia FBO demo but it wont run, it gives me
‘Unsupported framebuffer format’
How do I debug this?

I’m using 78.01 on a 6800 Go.

The demo is here…


Aren’t FBO, even if in a limited sense, supposed to be supported by even TNT-class hardware?

I assume u have a laptop,

so the driver yopu have will need to be updated.
And you cant just download it from nvidia, u need to go to your laptop manufactor.

I think you have specified Anisotropic filtering in driver panel. Set it to appliaction controled and all will be allright.

I’ve tried the Dell drivers (78.11). Anisotropic filtering is off. I still get the same error.

Has anyone with a Geforce 6800 GO got FBO working?

geforce 6800 Go, eh? Who’s a lucky boy?

Try OpenGL Extensions Viewer . There is a FBO rendering test. And you can compare the performance against the ‘PBuffer’ version.
Install it, go to Rendering Tests, check ‘EXT_framebuffer_object’ in ‘Framebuffer Effects’ and see if it is working.

The cube is not rendered at all when ext_framebuffer_object is selected. It works fine when it isnt selected.

Impressive website btw.

I have found that having any setting other than ‘application controlled’ for anisotropic filtering will break FBO…even forcing it off. It would be nice if this wasn’t the case, since it is a confusing problem to deal with, considering people use the driver forced settings for a variety of reasons.

Thanks Alex, you’re absolutely right as was Matt (I misread his post).

This is a major issue with FBOs, are NVidia aware of this bug? I’m suprised this hasnt been mentioned here before.

Hi Adrian,

Thanks - and yes, NVIDIA is aware of this problem. It has been fixed in internal drivers that should make their way to the public web site soon.

Thanks -