Getting started is going no where

First off I am new to openGL. I am a computer science student taking an intro graphics class but its still a lvl 5000 class, go figure the pun. I want to do my projects in Java using IBM eclipse or NetBeans but prefer eclipse. The computers at school don’t even run eclipse with openGL. Please :confused: hlp with the following or just give me a straight up answer to solve my horror =D.

How do I get glut and what is jogl?
How do I bind?

I just need to get either ide running with a simple openGL program to test it. If you have a nice answer, I will be forever in your debt.

JOGL is “Java bindings to the OpenGL native 3D graphics library.”

This should help :

Still confused but much thx for the above help. I I tried an example program in JAVA under eclipse. The 3rd import statement is this.


net ~~~~~ can not be resolved.

NOTE: I have included the website for the example programs that I am using and all other important files needed. The program is called “cube”. There is only 1 zip and its called

The help file is this…

The zip file in this directory contains the Java versions of
the sample programs in Angel: Interactive Computer Graphics,
Fourth Addition. They use the JOGL implementation of OpenGL
(included). The zip file also contains the necessary make files
for Linux and Windows.

And to answer your question. No I can not ask the author of the book because my professor will thinking I am cheating. Honestly I am not even sure if he knows HOW to do this or just wants to make my life difficult…

I don’t think I really said what I needed. Where do I put the files from the zip file?

sorry in advance…

Click my link above.
Click “downloads page”
Read info at the bottom about the Eclipse plugin :
“Just unzip the file into the plugins directory and you’re ready to go.”

You need to learn to RTFM :slight_smile:

I have tried this and this is what i get…

Error: Access is denied.
Cannot create C:\Program Files\eclipse\plugins\org.j3d.opengl.swt.draw2d_0.7.0.jar

disk is not full, and the jar file is not in the directory, i checked it aswell to be sure

okayyy… check you do have write permission to the plugins directory.

If not, then try this :

If you still don’t have write access to the jre/jdk path, extract elsewhere, and add all the jars to your Eclipse project.

Anyway, the official JOGL documentation and forums would be better suited to help you :

Originally posted by ak1200:


The above import line is outdated. Change it to the following line for new version of java (e.g.:v1.6.0):

But, GLUT is located in a different package:
import com.sun.opengl.util.GLUT;

I noticed many JOGL tutorials from the net are outdated and won’t be compiled with new version of JAVA.