Geforce 3 woes.

I know this isn’t really the place for this, just wondering if anyone has any magic tips to help solve this.

I have an ELSA gladiac 920 (Geforce 3) just freshly installed into my system. Athlon 1ghz, VIA KT7A chipset. Win98, drivers 11.01.

The system works fine, but after about 5 minutes from booting, I get lots of visual artifacts on screen. Appearing now. They appear very quickly when running 3D applications. AGP driver is on standard not turbo, all my BIOS settings are crancked to their minimum, and still it happens. After soo long it totally locks my system. Gfx card is irq 11, with only ACPI sharing irq 11.

Is this a hardware thing, via thing, or driver thing? Anybody know?


Unfortunately I don’t know the answer to your question, but I was curious about where you obtained such hardware?

– Zeno

i’d try installing the latest via service pack

I got it from Nvidia, as part of the Gathering attendee deal.

I’ve installed the latest VIA 4 in 1 drivers. Even tried using the standard mode AGP driver instead of Turbo. ELSA technical support are closed all weekend!

It locks my system up too… to the point of not being able to do anything. I’ve had to change back to my old card for the time being.

I also managed to reserve an irq for the gfx card alone… but still made no differnce.

The mainboard is an ABIT one… if I failed to mention that before…

Matt, Cass… any ideas? Surely some ppl at nvida have these cards… anyone experience screen corruption with them? Should I try installing Win2k?

I guess I’ll have to wait until Monday to phone Elsa tech support.

Thanks anyway… if anyone has any info at all about screen corruption fixes in via chipsets, please let me know ASAP!


hm… 12.00 driver is out… have you tried those, too?

I’m just about to try those now.


Well it took me a while to get them installed, due to it not booting up… but finally it’s up. I’m still getting a small amoumnt of screen corruption… but it aint crashed yet.

I turned both my drives from UDMA to PIO… I think there may be some connection… dunno…

still intermittant corruption occuring now…

hasn’t locked up yet though, which is good.

I think I’ve fixed it.

I’m using 12.00 drivers.

I did the following 3 things.

  1. Used block transfere for page flip technique.
  2. Disabled support for enhanced cpu instructions (athlon)
  3. Disabled anisotropic filtering.

I’ve gotten through a q3 demo, mad onion demo, crytek demo, and I’ve got no corruption or lock-ups anywhere…

I assume it’s one of those things then. Unless the card is deciding to play ball just for the moment…


Never seen it with mine, but I don’t touch Via chipsets with a ten-foot pole.

  • Matt

Originally posted by mcraighead:
[b]Never seen it with mine, but I don’t touch Via chipsets with a ten-foot pole.

  • Matt[/b]

Right, you were BX guy, right…

Which motherboard do you have now?

It’s stable now… Q3 in 2048 x 1500 at 40 odd fps is right nice! Q3 works fine… but I still got corrupted textures in Serious Sam after about 20 mins play… didn’t lock my machine though. And the corruption stoped once I quit SS.

Maybe once people start buying them and testing them more, some patches may arise to fix this.


I still use BX. I would suggest the i815 or the AMD 760 to new buyers… the KT133A is all right, but I just don’t trust Via.

  • Matt

I had exactly these problems when I tried to overclock my old TNT.
BTW: Is it possible to to have two desktops with different resolution on Win98/2000 on a geforce 2 mx 400 twin?

Originally posted by mcraighead:
I still use BX. I would suggest the i815 or the AMD 760 to new buyers… the KT133A is all right, but I just don’t trust Via.

I have found VIA chipsets (Apollo Pro and later) to be no buggier than Intel chipsets, and to have reasonable performance. The main problem is that they are cheaper than the Intel chipsets, and thus go on most twenty-dollar motherboards where the manufacturer may cut corners in validation, testing, or BIOS. Thus, when someone buys a twenty-dollar motherboard and has problems, they blame VIA, rather than their own stinginess.

I’ve never had a problem with a VIA chipset motherboard made by Tyan or Asus. Of course, I’ve never had a problem with BX, GX or i8xx motherboards made by the same companies, either (except the i810 only allows built-in graphics, which is slow as molasses in winter).

hm… nutty… think your problems are gone, arent they? i just took a look at the nice little screenshot at your page

Yeah, over 5000 Mad Onion marks aint bad is it! Should get higher, if this damn cpu weren’t multiplier locked! Problem seems to be gone… I was running q3 demos in stupid resolutions well into wee hours of last night, and no problems. Still odd that Serious Sam got corrupted textures. Haven’t tried that today… might give it ago.


you are the first that can see the naturedemo in the gamesection of 3dmark2k1 ( and the pixelshader demo,too )

and, how do they look like?

The nature bit in the benchmark is similar to the one in the demo, but there is a pixel shaded lake, that the river runs into. Looks right nice.

The pixel shader test, is a night scene at sea, with rolling waves reflecting the low lying sun on the horizon. Very nice too…


I had a similar problems with my home PC (Athlon 650Mhz, VIA KX133, GeForce2 MX) + Win2k. Well, in fact my problem was in the MS memory managment (Win2K) + Athlon processor. Nothing to do with NVidia and Via. I also thought, that it is related to Nvidia, since the crashes appear in their driver(I was able to trace several times the crashes, after stopping and debuging my app, when the corruption occured. The crashes occur in the drivers(Access violation).)
But the problem in not related to Nvidia. This is some kind of memory corruption caused by MS win2k memory managment + Athlon. It appears also with Matrox G450.

This patch completly solved my problem:

Hope this helps

Just thought I’d pipe up briefly and mention that it sounded like a heat problem to me. That theory slips if you were simply able to press ‘reset’ immediately after lockup to get it up again, though…

I recently put in a third video card. Had very strange system behavior. Popped open the case to make sure all the cards were seated firmly and was greeted by a wave of heat… More ventilation and the system is fine, now.

– Jeff