Full-Screen X Window

Whene I create a Full-Screen window with glut, my kde’s bars are on the window.
How can I resolve this problem?

The Tcl/TK libraries have this same problem?

Tnx very much.

Bye

Hi,

well I think it’s mostly GLUT’s fault. GLUT uses afaik only the motiv-window-manager-hints to get a fullscreen-window. Therefore fullscreen usually does not work with non-motif window-managers (i use gnome with icewm). This fact is part of the reason why i dropped glut and now use plain GLX with OpenGL. This seems to work with most/all(?) window-managers/desktops (several people tried it out without any probs).
But if anyone gets GLUT-fullscreen working with icewm i would be glad to know…

bxe Miq

Hi !
I wouldn’t say this is GLUT’s fault. I’ve got the same phenomenon (kde’s bars) with a pure X11 coding. However, this doesn’t happen with Gnome.
If I’m not wrong, preferences we indicate to the window manager (such as a 0 border width) can be overwritten by the WM itself. They are only preferences not “orders”.

Bye.

Hi Anne-Gael,

ok, perhaps it is not GLUT’s fault in the case of KDE, but in the case GNOME/<almost any windowmanager> it is GLUT’s fault. My GLX-apps and Q3A work perfectly in fullscreen, whereas GLUT-apps fail to.
If you set the override-redirect flag for a window, the window-manager should not tamper with the window. If KDE/KWM ignores that then it is KDE/KWM’s fault, since in that case it misbehaves, not the app.

bxe Miq