FPS drop in extended desktop mode

System Configuration:-

  1. ‘2’ AMD Opteron 64-bit processors
  2. ‘2’ Geforce 7800 GTX GPUs (NOT connected in SLI)
  3. ‘4’ VGA Monitors, 2 monitors to each graphics card (Horizontal span mode) i.e I have to 2 horizontal spans one on each graphics card. I had also disabled Vsync for both cards. Each horzontal span is (2048 * 768). Also for the 2nd horizontal span, I set it to extended desktop mode.

Situation:- (Refresh rates are set to 60Hz)

  1. Horizontal Span + Extended desktop mode + GLUT window size (4096 * 768)
    FPS = 20

  2. Horizontal Span + Extended desktop mode + GLUT window size (2048 * 768) - window doesn’t cross the 1st GPUs boundry. FPS = 20

  3. Horizontal Span + Extended desktop DISABLED + GLUT window size (2048 * 768)
    FPS = 45

My FPS halves when I use extended desktop mode (although my window does not span the 2nd GPU, CASE 2). So I guess it is not the problem of loosing hardware acceleration when using multiple GPUs. I cannot bring down the refresh rates.

How can I get around this problem ?

You should ask this question in advanced opengl programmers forum.

@silkut : well it is more related to windows than advanced GL, I do think here is the best place for this question.

I have played a bit with a 6800 connected to 2 monitors, and the various ways to extend desktop across monitor do really change performance.
Not totally sure but I seem to recall that the fastest way was to let Windows believe that there is only one wide monitor, and set appropriate settings within NVidia display control panel.
As names are pretty different in french I am not sure if it is called “horizontal span” or something else.

But I am pretty sure that there was a performance drop anyway, running Doom3 in one on the 2 monitor was clearly slower than when other monitor was disabled.

EDIT: maybe you are transfert limited. With 2 cards the driver probably sends data twice, once for each card. Can you benchmark with say 10 times less triangles/textures ?

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.