how to use it?


no of them is defined…xcode 2.2 os10.4.3

—> can’t find it in the gl.h?

it seems that apple has to update the gl.h…

here is the solution: http://www.idevgames.com/forum/showthread.php?t=10670

how can i avoid to use glew or something like that?

The functions are in my glext.h (Mac OS X 10.4.4, Xcode 2.2).

glext.h is included by gl.h on 10.4, so you shouldn’t have to do anything special.

very strange - it seems that i have not the latest opengl.framework. but xcode package is definitly 2.2.
my glex.h starts with: Copyright: © 1999 b…

can’t find the downloadable framework somewhere. is there a download possibility or could you share me your glext.h?

I’d suggest that if your OpenGL framework headers are not correct, that you have worse problems than can be solved by my giving you headers :wink:

Make sure you’re using <OpenGL/gl.h>, not the <GL/gl.h> that’s in /usr/X11R6/include.

I’ve put my OpenGL.framework’s headers at http://onesadcookie.com/~keith/OpenGLHeaders.zip

i am using the correct headers but it is just not defined in there (glext.h)

your package only contains an alias to your files…

uh, whoops.

Try that again :slight_smile:

thanks. very strange - don’t know why my .hs have’nt been updated correctly.

the fbo works now but the program crashes if i use a glClear call after glBindFramebufferEXT

There was a thread about that on the mac-opengl list recently. Archives are at http://lists.apple.com/ . IIRC, it turned out to be an NVidia-specific bug.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.