FBO problem

when I run the nvidia SDK demo of the FBO, it works. But when I try to run the glew library, it exit:

 if (!GLEW_EXT_framebuffer_object)

Like that I don’t support the FBO - but in the nvidia demo it works!!
Can anyone help me? I really need FBO!

Run glewinfo (bin directory of glew distrib) to see if your card support FBO.

if you have in generated text file

GL_EXT_framebuffer_object: OK

glBindFramebufferEXT: OK
glBindRenderbufferEXT: OK
glCheckFramebufferStatusEXT: OK
glDeleteFramebuffersEXT: OK
glDeleteRenderbuffersEXT: OK
glFramebufferRenderbufferEXT: OK
glFramebufferTexture1DEXT: OK
glFramebufferTexture2DEXT: OK
glFramebufferTexture3DEXT: OK
glGenFramebuffersEXT: OK
glGenRenderbuffersEXT: OK
glGenerateMipmapEXT: OK
glGetFramebufferAttachmentParameterivEXT: OK
glGetRenderbufferParameterivEXT: OK
glIsFramebufferEXT: OK
glIsRenderbufferEXT: OK
glRenderbufferStorageEXT: OK
it’s OK you can use FBO.

When I debug It say:

error symbol GLEW_EXT_framebuffer_object not found

thanks oliver, now i know that my card support it. but why it doesn’t work?

Try with glewIsSupported("GL_EXT_framebuffer_object) instead of GLEW_EXT_framebuffer_object.
But if you know that your card support FBO don’t run the test and normally it works.

Right, but I want to run the test, because when I use FBO commands, like glgenframebuffersEXT, it compiles with no errors, but at runtime it crashes, with the access violation 0x000000 error…and I don’t know why!

with glewIsSupported(“GL_EXT_framebuffer_object”) instead of GLEW_EXT_framebuffer_object, it say that I don’t support fbo…

So to include the glew I do this:

-add the glew32.lib to the library path
-include the glew.h and wglew.h

perhaps is this wrong?

Stupid question: You did run glewInit () AFTER OpenGL Context creation?

If not, function-pointers are not initialized.


yes I run it! and I found a stupid error in my control method …uff! Thanks Jan! you save me