extensions missing?

I have come across something pretty wierd. A while back i posted about how i couldnt use GL_EXT_texture_compression_s3tc on my GeForce 256 DDR with the LATEST WindowsXP drivers from nvidia. Well i never was able to resolve that, i dunno why. Well now that i got my geforce 4 ti with driver version 27.42 (came with the card) for XP and i tried again to initialize this extenson and my error box comes up and says its not supported. Im using the glh funcs but i looked through the code and it looks fine, i have used a lot of other extensions before and they work fine.

Ok i just tried some more extensions, mostly the new extensions the gf4 has and they wont work either. Here is the list i have found dont work so far.

"GL_NV_texture_shader2 "
"GL_NV_texture_shader3 "
"GL_EXT_texture3D "
"GL_NV_vertex_program1_1 "
"GL_NV_occlusion_query "
"GL_HP_occlusion_test "

I really find it very weird that texture3d and texture_shader2 is on the list. What is up with this? Do the drivers i have not like opengl or something? Or did you nvidia guys forget to add these to det xp verison 27.42?


Hmmmm… odd. I have those same drivers on my GF2mx, and VP1_1 works fine for me. (Well I have access to it, but it dont work under VP emulation)

Should have my GF4 by Friday!! fingers crossed


VP1.1 emulation should work fine…

  • Matt

You told me there was a problem with it. I assume you mean it’s now fixed in your newest drivers. Can you tell me what version drivers will fix that?


No, there’s a minor issue in that, at present, invariant programs aren’t invariant in emulation (but they render right aside from that). However, aside from that, everything in the new extension should work 100%.

This won’t be fixed in any driver available soon.

  • Matt

Well Matt, what is the status on these other extensions i listed? (Im sure there are more i havnt tried all of them) Will we see a driver update soon that lets us gf4 users access all the cool stuff this card was hyped up about?

I still have no clue why texture_3d wont work. That is so wierd. Also i see all of these extensions in the extension string thingy but for some reason i cant use them.

Whats wierd is that the Grace demo uses 3d textures and this demo runs fine for me. Well besides it being slow cuz of my slow pos cpu. Yet i cant init GL_EXT_texture3D myself.

I did some peeking into nvopengl.dll and i found something cool. One extension string i saw was called GL_NV_fragment_program. Sounds pretty nifty to me. I hope this extension will surface sometime in the near future and work on the gf3/4. At least on the gf 4.


These extensions work just fine.

  • Matt

I dunno about newer versions of NVIDIA’s OpenGL SDK (haven’t bothered downloaded anything new lately), but the one I have didn’t knew about some extensions (the glh-utility that is), and therefore couldn’t accept some of the extensions you asked for. If I remember correct, s3tc was one of the extensions it didn’t knew about.

Have a look in, I think, glh_extgen.h (or something similar, it should have a note saying the file is auto generated). I think that’s the file causing the trouble. There is a function in there, with a lot of if-statements, searching for substrings, and then loading extension functions if a substring is found. If not all of the extensions you ask for is in that function, it will fail.

[This message has been edited by Bob (edited 03-20-2002).]

These extensions work just fine.

Well thats good to know.

Bob, thanks for letting me know about that. Ill check into it later when i get home after my calculus 3 test. Bleh.


Calculus test, huh? Had one myself today


I agree!

Well bob you were correct about that glh file. I investigated the glh stuff a bit more and i see i need to regenerate the glh_extgen.h file with the new extensions. Plus define all the new tokens in the glext.h header. I also got a newer glext.h file from nvidia’s site which fixed my s3tc problem.

Sure glad that test is overwith. Shew. It went well though. Hope yours did too.