disable vsync with Windows 7 ?

My OpenGL context (windowed) seems to be capped to 60fps.
I’m using a GeForce GTX260 with Windows 7.

Is there a way to disable this limit ? Does it happens only in windowed mode or fullscreen too ? I guess Vista has the same limit ?

Thanks !

vsync seem to be on default, you can change that at runtime with wglSwapInterval(0);

Try disabling the desktop window manager(DWM)/Aero.

When DWM is active and vsync is off, your application can still run faster than 60fps*, but Win7 displays your rendered content only with 60fps.

*You can check your fps with the fraps tool, for example.

Also watch your nVidia settings panel.

in 3D settings, the value “Vertical sync” can take 3 values:

  1. Use the 3D application Setting
  2. Force on
  3. Force off

wglSwapInterval(0); will have no effect if the settings are in “Force” mode.