DeviL image libary: Link error

Hi, I want to use DevIl (OpenIL) in my program as it seems so cool, but I set it up as it says to but when I come to compile I get a link error when the only utilisation is the initIL() function. I am using win98 and MSVC++ v5.0, this is the exact error:

DevIL.lib : fatal error LNK1106: invalid file or disk full: cannot seek to 0x3d38cac1

I have checked the obvious things but to no avail, has anyone else ever recieved such an error? Is it becuase I’m using msvc++ V5.0 and not the latest version? If it is then what can I do as its far too much hassle re-compiling the lib since you need all the external libaries!

I have re-downloaded the files and still get the same error?


The lib file that comes with DevIL is not compatible with MSVC++ 5.0. You will likely need to rebuild the entire DevIL source. Or, there may be a tool in your MSVC bin directory to produce a lib file from the dll, I can’t remember exactly.

I thought as much, The problem with compiling it all is that you need loads of other seperate libaries which some will no doubt have similar problems. I will see what I can do but otherwise I will have to wait until I get a newer version of C++…