Couldn't find OpenGL souce

I am trying to install a software called Geant4 on my linux machine and was getting problem with my openGL libraries. Now I want to download the openGL libraries source and compile again with gcc4.0.0. I have tried finding the source code in website but i had very little success.
Could anyone please help where I can find those libraires.
thanks for help,

The GL libraries are installed with your video card drivers.

Hi, I found out that GL libraries are installed on my computer. But I want to reinstall these libraies and compile them with new version of gcc. I am doing so because I am recieving the error
/usr/bin/ld: skipping incompatible /usr/lib/ when searching for -lGL /usr/bin/ld: cannot find -lGL
collect2: ld returned 1 exit status
make: *** [/root/g4work//bin/Linux-g++/A01app] Error 1
when i tried to run an example of Geant4.

I posted a message in the Geant4 forum and got the reply to recompile openGL libraries using gcc.
Could anyone please help me how could i solve this issue.
thanks for help,

Sounds like you have a 32-bit Geant4, and a 64-bit libGL, or vice-versa.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.