Could some kindly soul with a Matrox card help out

We’re still failing miserably to get Alien Flux (10mb) running on Matrox cards.
It just crashes out and leaves us no hints as to why.

Could anybody who’s got a G400/450/500 etc have a go with the game who’s got some knowledge of debugging these things and see if they can pinpoint the trouble?

I have a sneaky feeling it’s to do with gamma, and nothing to do with OpenGL.


matrox drivers are not very stable(this is a well know fact)… but anyway, some time ago i found an interesting hint about matrox crashes:

it’s not really much information about the actual bug, but i think this could be a good starting point.

Thanks; I don’t think that’s it though - we don’t even get as far as changing the screen mode. This is why I suspected it was the gamma code, which is called at around the same time.


Tried to contact Matrox devrel about it?

They’re not generally helpful. I’ve contacted them before and got no reply.


so, er, no-one has a G400 any more?


Matrox cards are useless.

You shouldn’t “support” their cards until they can write a decent OpenGL ICD.

Got a G500 at work, i can test it on monday if you want. Not sure it’ll be helpful though, if it does crash, i’m not really sure what i could report to you that could help you.


Ysaneya that would be very helpful. I’ve got a special debug build of the library which has the gamma code commented out. If the game runs I’ll know that’s what it is - but not why it doesn’t work of course


Is the download the same as in your first post?

There’s a few shenanigans to go through which would make debugging a little easier:

Grab 1.4 JVM from Sun:
Get zipped Java version of the game from:
Unzip game to c:\ somewhere
Get debug DLL from
Unzip into the same directory
Run the game from the console with:

java -ea -jar AlienFlux.jar >out.log

And tell me if it works! A number of .log files get produced which will be handy in diagnosing any strangeness.


Got some time to spare today, so i went to work and made a test. It crashed for me when trying to initialize OpenAL. I have installed the JVM 1.4.2


Starting Alien Flux 1.4b
Gamma set, gamma = 1.0, brightness = 0.0, contrast = 1.0
1244200 free out of 2277376
JWS Classloader looking for: lwjglaudio
Failure locating OpenAL using classloader:


java.lang.NoSuchMethodException: sun.misc.Launcher$AppClassLoader.findLibrary(java.lang.String)
Sun Aug 24 15:07:48 CEST 2003 at java.lang.Class.getMethod(Unknown Source)
Sun Aug 24 15:07:48 CEST 2003 at org.lwjgl.openal.BaseAL.getPathFromJWS(
Sun Aug 24 15:07:48 CEST 2003 at org.lwjgl.openal.BaseAL.create(
Sun Aug 24 15:07:48 CEST 2003 at org.lwjgl.openal.AL.create(
Sun Aug 24 15:07:48 CEST 2003 at xap.Game.init(
Sun Aug 24 15:07:48 CEST 2003 at xap.Game.main(

This was tested on a G550, Win2k and 128 Mb of RAM.

Let me know if you want me to do other tests.


That’s actually a red herring; it’s a benign exception which has in fact been caught and dealt with.

What’s happening is that it crashes after loading OpenAL when it starts to do stuff with the display.

Have you got a debugger anywhere you can trap the crash in?


Ok, so this exception has been caught, and the actual crash happens just after.

I’m not a Java programmer (well i know Java, but don’t use it everyday), so i don’t have a debugger; the SDK isn’t even installed. Is there one in the SDK that i could use? Will it work without the sources?


It’s not crashing in the Java code; it crashes in the native DLL. Unfortunately it crashes in such a way as to leave no log of where it goes wrong.


Try it with this new debug dll:

Unzip over the existing lwjgl_d.dll and run the game using the -ea switch as before.


Same results/logs.


Why don’t you just buy one, cas?
Quick browse shows a g550 costs about £75 brand new - maybe ebay will have a 2nd hand one cheap.

coz last weekend I actually ran out of money so badly I couldn’t even buy food for a few days…


Tried getting a job?