Catalyst 9.8, anybody else having problems?

I’m trying to get my small OpenGL 3.x test application running all evening long already with the new Catalyst 9.8 drivers. But somehow something seems terribly wrong with the entry points of the functions.

glXChooseFBConfig seems to be 0, glXGetProcAdress can’t find a function… I used my own code for resolving extensions, but I also tried with glew and I couldn’t get that running either. The application worked fine with Catalyst 9.5, 9.6 and 9.7 and it should be pure OpenGL 3.0 code.

Does anybody else have problems as well, or is it just me doing something stupid?

On Windows, there are missing entry point like glDrawArraysInstanced and glDrawElementsInstanced. So OpenGL 3.1 is partially supported.
The rest seems fine.

A good night of sleep (well, it was kinda short), has helped me out here. This morning, the first thing I tried worked ;).

I saw I called the glXGetProcAddress function to retrieve the entrypoints of all functions before I created a context. This apparently worked in the last couple of drivers, but now it doesn’t anymore (I could have known this, as glew also is initialized after creating a context).