Can't start XrSession on Pico Neo 3

Hello. I’m developing a VR app using OpenXR. It works perfectly on Oculus Quest 1 and 2, but if I try to run it on Pico Neo 3, everything goes fine (Loader Init, Instance Init, System Init, Session Creations, Visualized Spaces and Swapchains creation) until I start polling events with XrPollEvent in order to get session state changed and then start it. The session state changes ones - from UNKNOWN to IDLE, and then always stays in IDLE. From this point XrPollEvent always results in EVENT UNAVAILABLE. For the loader I use .so library that I got from Pico OpenXR sample from their official site, the Android Manifest is also from sample. Version of OpenXR header files is 1.0.14 (it is used in Pico sample. I also tried 1.0.24 headers with same result). Worth to mention that Pico sample is running perfectly on Pico Neo 3. So I’m trying to understand what can be the problem. Thanks.

The Pico devices are not yet conformant - I haven’t seen a conformance submission, looked at any recent samples, etc. I’ve heard some folks are trying out prerelease versions that are more conformant than their earlier stuff, but it should be considered “preview only” until they’ve finished the conformance process, at which point they’ll show up here: Conformant Products - The Khronos Group Inc