Can't link glew in Visual Studio 2013, Windows 8.1


I can’t link static libraries in my visual studio 2013 c++ project.

I downloaded latest glew-1.11.0-win32 and glfw-3.1.1.bin.WIN32

Set path to include directory (project Properties > C/C++ "Additional Include Directories")


Add path to lib files (project Properties > Linker > General "Additional Library Directories")


Add library names (project Properties > Linker > Input "Additional Dependencies")

glew32.lib (also tried glew32s.lib)

Define preprocesor GLEW_STATIC (it's visible when I remove this)

(project Properties > C/C++ > Preprocessor "Preprocessor Definitions")

When I build my project following error occur(can’t write at symbol so I put [at]:

Error 1 error LNK2019: unresolved external symbol _glewInit[at]0 referenced in function _main main.obj
Error 2 error LNK2001: unresolved external symbol _glewExperimental main.obj
Error 3 error LNK1120: 2 unresolved externals OpenGL.exe

When I want to comple this




GLFWwindow * window;

using namespace std; 

int main()
    glewExperimental = TRUE;
    GLenum error = glewInit();
    if (error != GLEW_OK)
        cout << "Error!" << endl;


    return 0;

Windows 8.1 on virutal machine(VirtualBox) and Mirosoft Visual Studio 2013

What I am doing wrong? In other topics on this forum this solution works properly.

When I remove this two libs from directories I got same error, so probably Visual don’t see these two libs. But path is set properly. Include path works, all header files are visible by intelsense.

Well, you don’t tell us what the exact error is, so there is no way to help. if you have a mismatch between how the library is built and how the application is built you will get problems though. I would just remake the glew as mt dynamic and do the project that way was well, don’t try to bother with the static because visual studio makes this a ridiculous pain.