Cannot create Vulkan instance ("non-conformant Vulkan implementation")

I have been programming computer graphics with Vulkan API for a while, rendering different objects and implementing different techniques without big problems. But now, all of a sudden, I receive two error messages, one after another, and then execution crashes:

WARNING: dzn is not a conformant Vulkan implementation, testing use only.

MESA: error: ID3D12DeviceFactory::CreateDevice failed

The vkconfig also says: Cannot find a compatible Vulkan installable client driver (ICD).

These errors appear when executing vkCreateInstance() and vkEnumeratePhysicalDevices(). The crash happens because vkEnumeratePhysicalDevices() is unable to find any physical device supporting Vulkan (despite they exist) making my application unable to work properly.

I didn’t have this problem before. Everything worked fine. Running older versions (from my repository) that worked fine in the past also get these errors and the crash too.

I don’t know, maybe there is some problem with the drivers. Maybe they were updated, introducing changes that are not Vulkan conformant. But, after updating the GPU drivers (from Nvidia) and the Vulkan SDK (from LunarG), the problem persists. I have been unable to solve this issue so far.

Maybe “dzn” is “Dozen”, which maybe is part of MESA (I think). However, I don’t know what does D3D12, dzn, or MESA have to do with this since I’m using Vulkan.

  • Discrete physical device (I pick this): NVIDIA GeForce RTX 3050 Ti Laptop GPU
  • Integrated physical device: AMD Radeon ™ Graphics
  • Vulkan SDK version: 1.3.275.0 (previously I used 1.3.211.0).
  • OS: Windows 11

Update: After updating AMD devices drivers, I no longer get the MESA error, but I still get the dzn error (weird because I only use the Nvidia GPU, not the AMD GPU). Also, the program crashes at vkCreateInstance() (access violation reading location X). Furthermore, vkconfig and vkcube (demo from Vulkan SDK) also crash.

1 Like

Not sure if this helps you any, but AFAIK dzn is a Vulkan implementation on top of Direct3D 12, similar to how MoltenVK is a Vulkan implementation on top of Metal.
One of its use cases is to provide accelerated graphics capabilities to the WSL (Windows Subsystem for Linux) parts of Windows. Are you perhaps running the failing commands from a WSL command prompt and were previously running them in the “normal” Windows environment?

I’m having the same problem. Yesterday, I could open Vulkan-supported applications, but now I can’t. I updated the driver, used DDU to uninstall and reinstall it, but nothing changed. Example Vulkan applications also don’t open. I downloaded “VulkanRT-1.3.275.0-Components” from the LunarG website. The x86 version works with a warning that “dzn is not a conformant Vulkan implementation, testing use only.” However, the x64 version only gives a warning. Sometimes GPU-Z shows that it supports Vulkan, but then it disappears when the application is refreshed. My system: R5 5600G Vega 7(Cezzane), OS: Windows 11.
Edit: Uninstalling the “OpenCL™, OpenGL® and Vulkan® Compatibility Pack” fixed the problem.

1 Like

Thank you for this. This solution worked for me as well. I never explicitly installed this “Compatibility Pack”, but it appears that it found its way onto my machine anyway, just a few days ago. That was when I first noticed this warning. I’m curious to find out what installed it. All threads I found talking about this online were only created a few days ago. That cannot be a coincidence.

Great job, StrayCat! You discovered the cause of the problem. Uninstalling the “OpenCL, OpenGL and Vulkan Compatibility Pack” fixed the issue. It was installed (maybe, automatically) the same day the problems started. It looks like this pack may have a bug.
This issue and its solution is also described in this SO question.