Bug with cos and sin

Hello,

When I call cos or sin in an
OpenGL+GLUT program, I get an
error :
BUG IN DYNAMIC LINKER: ld.so: dl-version.c : assertion “needed != (void *)()” failed
(or something like that)
Can anyone help ?
Thanks !

That’s some nifty error you’ve created there

Did you link the math lib with -lm ?

John

That’s some nifty error you’ve created there

Did you link the math lib with -lm ?

John

In fact, the bug appears only when
I have my drivers installed.
I think that the bug is in the drivers.
Thanks for having replied !

I got this same error and I recompiled the source code again and made sure to include the -lm option. My code now runs fine.

Also i replace my libglut.so with the one that is on the dri.sourceforge.net if you follow the resources think I think the libglut.so that is installed with x has some issues.