Big Problem with Performance

Hi everyone! :slight_smile:
I hope you all had a great week.

Let’s see if someone can help me with this puppy:
I am trying my fully-working 3D app on a college computer, and… everything is screwed up.

I got a 256 MB GForce Card at home and everything works like a charm. College’s computer characterists are unknown since they information is blocked ´by administrator´, but it´s a Pentium 4 (the case says it all :smiley: ).

Here, in college´s computer, textures don´t load correctly, the skybox textures don´t show at all or either show themselves colored like rainbow strips. Almost no textures get rendered, and not any of my 3d objects get rendered either.

The only thing that loads correctly with textures is a cloud layer drawn on the fly, and a floor drawn on the fly. Textures and alpha blending work there. All glOrtho events are also drawn perfectly with correct textures. Those textures used in the 2d interface are the same texture maps used in the 3d scene. So the bitmaps are actually loaded, but they just don´t render.

Of couse -it runs at 60 fps- since it´s not drawing anything!

Can someone help me untangle this puzzle?

One of my hypothesis is that maybe the card doesn´t support glCall Lists? Is that possible?
However the skybox that is stored in a list, is actually drawn, however not textured. On the contrary, my pool table , that is in a list too, is not drawn at all, not even one vertex. :confused:

For reference, I am using two objects consinsting of almost 1000 faces each, and 5 bitmap textures of 3MB each for the skybox, and other 5 TGA textures of 2MB for the mountainbox. This runs at home, at 25 fps when looking directly at the objects, or 60 fps when looking otherwise.

Thank you so much in advance,

You could still get which gfx card it is a friend culd programm u a dll or exe just pm me

Well, i would simply guess, that the gfx card or driver is at fault. Maybe it’s an intel integrated card, afaik their OpenGL driver support is pretty bad.

You could try to get the GL_RENDERER and GL_VENDOR (glGetString). That should tell you, which card and vendor it is.

Maybe there is no real OpenGL driver installed, at all, so you get a software fallback (although that might be slower than 60 FPS).

Sorry, can’t help you any more.

There is a very nice utility on, called GLInfo, that will tell you everything about the graphics card, it’s capabilities, driver version, supported extensions, etc…

You can get it here:

I finally got to test it in college´s computer again:

Driver version: unknown
Vendor: intel
Renderer: intel 865G
OpenGL version: 1.3

Everything loaded in lists loads weird.
My skybox is not a box anymore. It looks like a box with infinite height from any point of view. I cant see neither top nor bottom.

Models in lists dont load. Just run-time rendered planes load.

In my computer everything works perfect. What is it!!??!?!?

Originally posted by Rodrix:
In my computer everything works perfect. What is it!!??!?!?
Low end card vendors usualy have terrible quality of OpenGL drivers. Usualy that quality is much worse than quality of theirs DX drivers which are also bad.

As i said: Intel cards have pretty bad drivers…

Is there anything i can do!? Will downloading new drivers fix it? Thanks

Please someone HELP ME!!! :frowning:

My computer crashed because of a power shortage, and I had to reinstall the whole Windows from scratch.

I reinstalled the Video Drivers and everything and now I am getting the same problems that ocurred on the computer with the intel drivers!

GLInfo reads:

  • Driver Version: 6.14.105655
  • Vendor: NVIDIA Corporation
  • Renderer: GeForce FX 5500/SSE2/3DNOW!
  • OpenGL Version: 1.5.0

I am going nuts!
It’s the same program that before worked perfectly like a charm, and now I reinstalled windows and now it’s a mess. I am getting exactly the same problems I mentioned before on the computer with the Intel drivers: objects loaded through lists render screwed up. Some don’t load, and for example the skybox loads like a cube with some sides of infinite height (Can’t see neither top nor bottom of the cube) and thus all textures looked screwed up. Please someone help me!

The code should be ok, since before it worked perfectly… And I have alrady reinstalled the drivers twice…

Thank you so much in advance,

Originally posted by Rodrix:

  • Driver Version: 6.14.105655
    You have really old driver. It is version 56.55 which is aproximately two years old. Try to instal the latest certified driver (version 84.21).

I fixed it!!!

You guys won’t believe this (never did I)
the problem was with the Local Configuration Settings. No driver problem.

That is, my objects were loaded from a file format similar to OBJ but with comma-separated values, and both college computers as my most recent Windows installation had the comma as the decimal symbol instead of the period.

Therefore, if an objects vertex coordinates were:
vt 50.000000,50.00000,0.00000000

Depending on Local Settings Visual Basic would read it as 50 or as 50E6! I changed the decimal symbol to period and now the program works perfect!!!

However I am wondering how to handle this problem…
Do professional games use binary instead of ascii to store 3d model data?! Binary data is system-indepent right?!

Thanks so much everyone!