Assimp Runtime Errors (SIGABRT)

I’m having trouble setting up Assimp for Xcode. The binaries seemed to be compiled successfully however I get runtime errors (SIGABRT, signal abort error) when building the program with the binaries linked. Any ideas? I am using the latest version of Assimp. I tried building from Brew and tried building it from CMake but both of them return runtime error on the same stack trace. Thanks!

Here is some stuff that might help.

Error message

IDE Directory 1

IDE Directory 2

The source code is at this GitHub repository GitHub - husk57/LearnOpenGL

I want to just be able to reference the header files of Assimp without getting runtime errors. I have a strong feeling this is due to me using dynamic library binaries (.dylib) instead of static library binaries (.a) because I am extracting them using the same method with CMake and the glfw binaries were fine cause they were static? Who knows but what I do know is the runtime error says it is missing some sort of “image”

I have no idea why but building with CMake with the link from this website
https://assimp.org/index.php/downloads
which was just a proxy to the GitHub repo seemed to work, but going to GitHub itself and typing it wouldn’t work. This is where you would download it for any future internet explorers.