Antialising

I wanted to give Opengl’s polygon antialiasing a go using GL_POLYGON_SMOOTH, but it is not making a difference on my RAGE 128…
Does anyone know of any issues with AA on the 128?

Antialising works as expected on the Radeon on my laptop, with the exact same code…

Any clues would be appreciated.

This card has very bad OpenGL drivers. I’m not surprised at all it doesn’t work under linux. I would even be surprised if it worked under Windows.

Yes, ATI and nVidia are still not taking linux driver development seriously enough, from the looks of it - I’ll check their web sites to see what the state of things are…

Personnally, I use this function to set the polygon smooth mode:

glHint (GL_POLYGON_SMOOTH_HINT);

As you can see, this is a hint, only a hint, not an order to OpenGL. So, some cards may follow your rule, other might not. It can also depend on the drivers and the OS.

There may be some hardware issue with the Rage 128 that prevents it from working properly. You might try posting your code to the Mesa developer’s list . Basically, one of three things is happening.

[ol][li] There is a bug in your code. This isn’t very likely since polygon antialiasing is pretty straightforward.[/li] [li] There’s a bug in the driver and it’s incorrectly ignoring the hint.[/li] [li] There’s a limitation in the hardware and it has to ignore the hint.[/ol][/li]I’ve only done a little bit of work on that driver in the past, so I don’t know all of its issues. Someone on the Mesa list probably will.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.