How can I activate antialiasing on flat triangles ?
I’ve tried glHint and enabling blending but I can get it work only for lines…

Antialiasing of all primitives is enabled by using multisampling, see section 3.2.1 of version 1.4 of the OpenGL spec. You can also check out the [ARB_multisample](http://" extension spec if your drivers OpenGL version doesn’t support multisampling in the core.


This should work. Note that for poly smoothing to look correct on overlapping edges you need to depth sort your triangles and render them back to front. Otherwise you’ll get (minor) rendering artifacts.

If it doesn’t work at all, mind to tell us what graphics card and driver version you’re using?

I thought polygon smooth was a hint, not an enable? This means implementations are free to ignore it of course and IIRC my old TNT2 did.