An Error while running executable

Hello Everybody.

So I am pretty new to graphics programming, and well I still have a lot of things to learn in general (I am about to finish my first year of CS in college), so if this is an easy fix please bear with me, I am just trying learn.

Anyway, the situation is this : I am trying to make a suppppper basic program, to really just test that I can get vulkan working on my computer, I have a mac book pro btw.

I have followed this youtube video:

to the t but I ran into an error while trying to run a executable that I create. Here is the error:

% ./app
dyld[75247]: Library not loaded: @rpath/libvulkan.1.dylib
  Referenced from: <A87F93CB-EA87-307E-AC92-B1DEDDEEFFD6> /Users/reecehutchison/Code/VulcanTest/bin/app
  Reason: tried: '$/Users/reecehutchison/VulkanSDK/vulkan/macOS/lib/libvulkan.1.dylib' (no such file), '/libvulkan.1.dylib' (no such file)
zsh: abort      ./app

I have double checked that the libvulkan.1.dylib (it is just an alias pointing to another executable in the lib directory) is in the correct path, and it is. So this has left me pretty stuck.

I have tried to add the executable “libvulkan.1.3...” to and it’s alias being called in the error “libvulkan.1...” into my bin directory, where I am trying to run my app. I am just trying to execute a very simple hello world file in c.

Any help would be greatly appreciated and thanks for taking the time to read this.

If there is anymore information that I should have included in the post then please feel free to ask.

Thanks again!

I thought I would mention as well that I have everything practically the same as him in the video, and my error starts to happen around 25 and a half minutes in when he ./app …

My executable gets made and everything works up until that point where I am trying to run that file.

Also when using the test command to see if vulkan gets properly installed the cube shows up and it says its successful.

Anyways, thanks again for taking the time to read this!