AGP(PCI mode) Off-topic, plz ignore if it bothers you.

A few of my work collegeues have problems with Nvidia cards, in which that on the advanced settings screen, (the one with the spinny Nvidia logo) bus type is listed as AGP(pci mode).

This is on various systems. Intel and AMD usually on Gf2Mx’s. How do we force it into AGP mode? They’ve tried installing mobo drivers for AGP, and re-installing the drivers numberous times.

One of the weirdest things is that, setting PCI mode texture memory in D3D settings to 0, provides a noticable speed-bump, as though it was suddenly switching to AGP mode.

Any ideas how to make it natively AGP, or is it a GF2 architecture thing? Perhaps Matt might be able to shed some light as to why this happens, as we’ve had no luck with Creative tech support.

Thanks, and sorry for being off-topic.


I’ve never seen that problem on my system. I’ll have a look see on my friends computer who has a similar setup as mine, but my rig has the following…
Intel Pentium III @ 1GHz
MSI MS-6365 (Apollo Pro 266)
Win2k SP2 SR1
Latest Via 4-in-1 drivers (for sure, non beta’s)
Latest Det’s (I think, at work right now)
VisionTek GF2MX/400 64MB


So PCI mode means that AGP memory is not used when needed and the card just behaves like a PCI card when its out of texture memory?

Have you tried the allocate functions wglAllocateMemoryNV

This could be related to that other thread where it was mentioned that some systems werent trusted for the AGP stability so AGP was knocked down to 2x or 1x by the NV drivers…


Nutty ive had this before,

>>Latest Via 4-in-1 drivers (for sure, non beta’s)<< seems to do the trick for me

I don’t know how to fix this through the display control panel but … nvMax has an option to do force AGP 4x …

I have this EXACT same problem, I have a Geforce 2 MX, 32 mb, Athlon 1 gig, and It started as soon as I updated the drivers to the newest version, 28.32 i think.
Please help me fix it.

nvMax will fix it

i’ve the same problem. hope nvmax will fix it. i don’t have a asus or other board wich is wellknown, so doing a driverupdate is quite difficult somehow as i dont know what it is