Accessing elements of dvec arrays

Hi, I’m using ARB_gpu_shader_fp64 extension on Nvidia (R270.61 on a 460 card), and encountered a problem in accessing elements of dvec arrays:

out vec3 val;
uniform int sel;

void main()
    dvec3 dary[3] = dvec3[](
        dvec3(1, 0, 0),
        dvec3(0, 1, 0),
        dvec3(0, 0, 1));

    val = vec3(dary[sel]);

Using a uniform or varying variable as index with the array behaves as if the index was always 0. Constants work OK. Of course, using a vec3 array in stead of dvec3 there works as expected too.

Btw - does anyone know how to submit reports to Nvidia? I’m a registered developer there but the nvdeveloper site seems to be pretty much dead, and none of the mail contacts there work either.

Thanks -> Report a problem. That’s still active – submitted a report about a month ago and got a response.

However, I see what you see in that they no longer seem to use that site for posting early release drivers.

Do you mean “-> Bug report” there? I’ve tried that one too, some time ago, but never got a reply either :frowning:

No, says “Report a Problem” here. And I “do” get responses. NVidia’s pretty good about looking into issues if you can give them a simple test program that illustrates the problem.

That’s weird. I can see “Report a problem” on the left side menu, only after clicking on “Software” button in the upper banner. But clicking on the “Report a problem” there gets me a plain page saying “Not ready yet.”

The whole site seems as if frozen in 2007, no newer content :confused:

Edit: this is what I’m getting for

Odd. Try disabling any adblock/noscript/firewalls/filters/etc. you might have enabled.

That said, I run with AdBlock, NoScript, and a number of others and have no problems once I allow scripts on the site. This is with Firefox 3.x or 4.x.

I have only Adblock, disabling it did nothing except showing Nvidia banner. Tried with FF4.x and Chrome 11

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.