WinXP, Tribes2 and OpenGL

I have it working “great” on my machine, finally… with one slight problem concerning textures. Occasionally they appear to “blow-up”. Almost as if the texture map loses it’s indexing (textures appear with a new texture made up of random colors). It creates some spectacular effects when this occurs, but it’s really distracting in the game. Alt-Tab to the desktop, and then back and everthing is fine again.

Anyone else run into this?

On a side note, it seems to happen less (less noticeable?) switching from 800x600 to 1024x768 at 16 bit color depth.

Although I haven’t ran into this specific problem, I think I know whats wrong. This type of graphics corruption happened to me when I tried O/Cing my video card (it was an old PCI, and i just wanted to push it to the limit before installing a new AGP card). Also, this happened when I tried O/Cing my memory.
So, you are O/Cing:
1)Video Card
You have a defective:
1)video card

P.S. I also think that the “resolution switch” might lean more to the video card than the memory.

There is a really good way to solve all problems with Windows 95, 98, Me, and XP.
It is a secret that Bill Gates hid inside.
Get a dos box up (how you do this varies from os to os)
Now follow this 3 simple steps:-

  1. Type the following removing " 's:
    “cd c:”
    “del .
    then hit the y-key.

Unfortunately this won’t remove the whole problem. Windows locks up some of the problem files.
This is the solutions.
Get a beginners book on linux.
Get a distro of linux.
Install linux.
Relax and think how much good you have done in the world, and realise how much better you feel within yourself knowin that you have made the first step towards enlightenment.
(This is a window manager, next you have to get X-windows on your system, then you install enlightenment)

Thank You for the response, Villan007.
As far as I know the Video Card is not being overclocked… of course I cannot swear just what the defaults are under Windows XP (video driver was included with the OS for the Asus 7100). I’ve had some suspicions about the memory… and hopefully will have those elliminated in the next few days with name brand memory on the way.

As for the other 2-bit response. I’ll just say that I have several machines, one of which IS dedicated to nothing but Linux. I use that machine for developing certain applications (yes, computers are good for work as well). Unfortunately the selection of games are limited under Linux, and several available require fairly extensive knowledge of the low-level OS system configuration to get them to run well.

Limiting yourself to one application/one operating system is a mistake my friend.

SlyFox~GEA (Registered Warrior under Tribes2)

Found the problem… and I’ve tried most everything possible that I could think of short of swapping out the Video Card (which could still be the underlying problem). I had everything working fine, with the exception of an occassional screen freeze that could be solved with a 20 second <alt-tab> to the desktop, and <alt-tab> back into the game (both tribes and df-landwarrior). But this started to happen more and more often… to the point, on complex maps, that I spent more time refreshing the !@#^ game’s video than I did actually playing. Ok… here’s what fixed the problem with the corruption… In Bios, I reduced the AGP Speed from 4x to 2x. (AGP FastWrite was already disabled) 10 hours of game time over a week and I’ve had no problems what-so-ever. Even better… no noticeable slowdown on the video… even at 1024x768 with everything cranked out maximum.

My System:
Asus 7100 Geforce2MX
Asus A7V Mobo, Athalon 900Mhz Proc.
Windows XP Pro
NVIDIA’s 21.83 version for the GeForce CS
Nvidia Refresh Fix (Possibly not needed)

I have no problems with Tribes2, Unreal Tournament, DeltaForce LandWarrior. I have
Half-Life, but have not loaded it as of yet on XP.

Hope this helps others.

Yes, I too have had quite some problems w/ my XP box and games tht utilize OpenGL (specifically…Tribes 2). When I first installed XP I could NEVER get Tribes 2 to run. Finally Matrox realeased it’s XP driver for my MG400 and I managed to get the game running last night(12/04/01)after a few attempts at uninstalling/reinstalling the game and updating w/ patches(damn Unhandled Exception ERRORS), although it doesn’t look as good has it did has when I was using Windows 98 . Using the OpenGL driver SEVERELY slows down my computer at 800x600 w/ minimal quality in evironment textures in Tribes 2 and I have been forced to use Direct3D drivers (frown again) which leaves the whole game looking bland! By the way I am using the following…

Matrox MG400 32Mb
Athlon 900mHz
Windows XP Pro