[Update] Crash when constructing DAE object.

When I attempt to construct a DAE object the debug build of my application application crashes raising the following exception:

“Unhandled exception at 0x0081d8ed in GLTest.exe: 0xC0000005: Access violation reading location 0x00000000.”

I’ve investigated and it fails to construct the following regular expression object:

static pcrecpp::RE re("^(([^:/?#]+):)?(//([^/?#]*))?([^?#]*)(\\?([^#]*))?(#(.*))?");"


I built the COLLADA_RT project and it produces the exact same crash at run time, also only in the debug build. The the release build runs successfully and produces an output as seen here: ImageShack - Best place for all of your image hosting and image sharing needs. (PS. Is this what the COLLADA_RT output supposed to look like?)

I have no clue whats going on. Any help would be much appreciated.

i’ve got your same problem

I’ll take a look at this tomorrow. What version of Visual Studio are you using?


Visual Studio 2005 (full version, not express)

I was going to say I think the problem is that we’re using a VS 2005 build of PCRE, even when using the DOM with VS 2008, and I think that’s causing problems. But it looks like you’re seeing the issue even with a 2005 build of the DOM.

We’ve had problems like this before when a lib was built using a VS 2005 at a different service pack level than the one used to build the final exe. Do you have VS 2005 service pack 1 installed? I think you can find out by going to Help --> About Visual Studio.


Since I haven’t updated Visual Studio I assume that I do not have service pack 1.

RT debug works fine for me. That’s not really surprising of course.

I’m waiting for our IT department to get VMware installed so I can try working with a perfectly clean Windows image. I probably won’t have any more updates until then.

Can you try running the debug version of the domTest app? It uses the DOM DLL instead of the static lib and I’m curious to see if you get the same error. Run it as ‘domTest -all’. You should get a message that all tests pass.

Could you get me the full version number anyway, or just confirm that it’s the same as mine? Mine is 8.0.50727.762 (SP .050727-7600). Thanks.

It looks like the materials aren’t rendering correctly there. To be honest RT has many bugs and it doesn’t surprise me if it’s not rendering your model correctly. I don’t work on RT myself. We have a guy that works on it sometimes, but frankly it doesn’t get much love anymore and it’s hard for me to recommend it. If you want you can file a bug on Sourceforge.


Also, just to be clear, you’re working with a recent checkout of the svn trunk, right?

Ok, I got VMware setup and tried building the DOM trunk with a (mostly) clean XP image. The image came with VS 2005 already installed. I noticed that Visual Studio reported a different version than my normal Visual Studio install. It said it was version 8.0.50727-4200 (RTM.0507270-4200).

I installed CG then built RT and found that it didn’t run. Neither debug nor release mode worked. I got an error that the application wasn’t installed correctly or some such. I installed the Visual Studio 2005 Service Pack 1 redist and then RT worked fine.

Can you install that redist and see if it fixes things for you? If it does, I might go back and rebuild the release packages using an unpatched version of Visual Studio. That might get us better compatibility. Please do get back to me on this.


Sorry about the delay, I’ve been consumed for the past little while.

My visual studio version is: 8.0.50727.42 (RTM.050727-4200), I have yet to apply the MSVC service pack you mentioned, but I’ll likely try it out within the next few days.

However I manged to get things working in the meantime by linking against the DLL version of the library.

Any problems should be fixed in DOM 2.1, which I put up on Sourceforge yesterday.

So is that to say DOM 2.1 is in the SVN trunk?

Also 2.1 specifically refers to the API version, not the schema right? The versioning of the API and schema have me a little confused

> So is that to say DOM 2.1 is in the SVN trunk?

Yes. It’s also up on Sourceforge.

> Also 2.1 specifically refers to the API version, not the schema right? The versioning of the API and schema have me a little confused

Can’t blame ya, it is a bit confusing. 2.1 refers to the version of the Collada DOM, a library for working with Collada documents. DOM != Collada though, and Collada is versioned separately, currently at 1.4.