Recording problems in OpenGL

One of my hobbies is recording playthroughs of old-ish games for Youtube. Fraps used to run great a while ago, but I recently got a virus that tried to slow my computer down by writing to the hard drive a lot, which made it start failing (it was failing anyways, the virus just pushed it closer to the edge to the point where it was noticeable). I replaced the hard drive with the exact same model, transferred the contents of the old to the new (SATA <-> USB cable and the DDRescue command, which copied the hard drive completely, sector for sector), cleaned out the virus entirely, defragged, etc. Unfortunately, now I’m having trouble.

Whenever I try to record in OpenGL, my frame rate drops to 4fps, no matter what game or graphic settings. Direct3d and DirectDraw record perfectly fine. I’ve tested with multiple games, especially ones that can switch between DirectX and OpenGL. It worked perfectly fine before the virus, and it works fine when I’m not recording.

Can anybody help? I’m running out of places to look for the problem. I asked on the Fraps forums as well, but no luck there and I figured it couldn’t hurt to ask here, too.

Maybe FRAPS hooks to the default software GL renderer instead of the accelerated GL driver, but that really seem to be a problem on fraps side.
Can you try Taksi, to see if a different tool has the same problem ?…ev.msi/download

Hmm, Taksi seems to be recording it okay (though I had trouble getting it to start recording in general, so I’m not sure it would have hit the same problem). If this is a Fraps problem, however, wouldn’t it have resolved after I reinstalled it?

This is a question best asked to the Fraps team. Anything can happen, like reusing previous bad settings, have the autodetect fail in the same way, etc.