quake3 needs opengl32.dll - help ready to give up pc gaming!!!!

I loaded all the latest drivers from
the nvidea site that have opengl support.
I have the TNT2 PRO.

When I start up Quake3, I get this:

Initializing OpenGL subsystem
…initializing QGL
…calling LoadLibrary( ‘C:\WINDOWS\SYSTEM\opengl32.dll’ ): failed
…shutting down QGL
…assuming ‘3dfxvgl’ is a standalone driver
…initializing QGL
…WARNING: missing Glide installation, assuming no 3Dfx available
…shutting down QGL
----- CL_Shutdown -----
RE_Shutdown( 1 )

GLW_StartOpenGL() - could not load OpenGL subsystem

Help!!! What do I do?!!


Every Window system should haveopengl32.dll so check that you have it. If not do you perhaps need to reinstall Windows.

did you have a voodoo in before? Or opengl got confused somehow. Make sure you remove the files glide32.dll/GLIDE32.dll and/or all 3dfx/voodoo drivers and registry entries. My Nvida drivers got all freaked-out by the above mentioned files.

Search this forum about the error “could not load OpenGL subsystem”. It’s a game issue, not a card specific problem, and I remember someone posting a solution some months ago.

God, this should really be made a FAQ. Seems like half the questions in this forum are about this error.