Quake2 Open GL with Nvidia Riva TNT2 Pro does not work HeeeelP


Graphics Card: Riva TNT2 Pro
Driver version

I can see the OpenGL installable client
driver in the display properites window.

I go to run Quake to and set Open GL in the
Video selection in Quake and the Quake 2 server halts and it reverts to software
mode. It finds nothing. Like the driver is
never loading.

HELP! What can I check? What do I do?


maybe look in your Q2 folder and find a file called OpenGL32.dll
Remove it, cause it’s probably an old version and it doesnt work w/ your card(the game will then use the opengl32.dll that was installed w/ your card’s drivers).
Hope this helps

uhm… if there is no opengl32.dll in your q2 folder… i don’t know how to help any more xept to say… get the most upto-date drivers.

I checked, there is no opengl32.dll in the folder. I tried to start Quake3 and I get
the following:

Initializing OpenGL driver
…getting DC: succeeded
…GLW_ChoosePFD( 16, 16, 0 )
…23 PFDs found
…GLW_ChoosePFD failed
…GLW_ChoosePFD( 16, 16, 0 )
…23 PFDs found
…GLW_ChoosePFD failed
…failed to find an appropriate PIXELFORMAT
…restoring display settings
…WARNING: could not set the given mode (3)
…shutting down QGL
…unloading OpenGL DLL
…assuming ‘3dfxvgl’ is a standalone driver
…initializing QGL
…WARNING: missing Glide installation, assuming no 3Dfx available
…shutting down QGL
----- CL_Shutdown -----
RE_Shutdown( 1 )

GLW_StartOpenGL() - could not load OpenGL subsystem

and the game never loads!

I tried going back to VGA mode and then
loading the latest drivers from nvidea
prior to this. Quake2 does pretty much
the same thing.