Quake 3 and opengl problem

whenever i wonts to start quake 3 there comes in the console:

Q_strncpyz: NULL src

and that is a peace of the console:

…assuming ‘3dfxvgl’ is a standalone driver
…initializing QGL
…WARNING: missing Glide installation, assuming no 3Dfx available
…shutting down QGL
…initializing QGL
…calling LoadLibrary( ‘C:\WINDOWS\SYSTEM\opengl32.dll’ ): succeeded
…setting mode 3: 640 480 FS
…using desktop display depth of 16
…calling CDS: ok
…registered window class
…created window@0,0 (640x480)
Initializing OpenGL driver
…getting DC: succeeded
…GLW_ChoosePFD( 16, 16, 0 )
…27 PFDs found
…hardware acceleration found
…PIXELFORMAT 2 selected
…creating GL context: failed
…failed hard
…restoring display settings
…WARNING: could not set the given mode (3)
…setting mode 3: 640 480 FS
…using colorsbits of 16
…calling CDS: ok
…created window@0,0 (640x480)

can you help me please???

i have the matrox g400 millennium

First: try to update OpenGL, DirectX, Videodrivers AND chipset drivers (espessialy VIA chipset’s)
iff ur problem stil is there, it might be the computer power (an old computer or so)
then i sugest u buy a Spitfire (Duron) as it’s faster than an equal P3

des hab ich alles schon prob. funtzt aber net

I got a Dual system and running on Windows2k with a matroxG400 and Q3A runs great. actually it runs much faster then 9x. After running W2k i will never go bak 2 9x. Neway the way i fixed Q2A was 2 find a OPENGL32.DLL file with the BYTE SIZE 676KB DATE: 12/7/1999 and replace it with the 1 u have now in your SYSTEM32 DIRECTORY. RUN THE GAME! IT SHOULD WORK. IF IT DOESNT WORK THEN I REALLY DUNNO WHAT IS THE PROBLEM.

and Oh btw i think my fix is 4 matrox vdo cards.

Hope this helps!


1 more thing.
in your WIN.INI file
add the ;DVA=0 on 1 of the lines
well, that wot i did and Q3A works.
So try that…CIAO!