Problem running opengl programs

I have downloaded a lot of opengl programs from, also got a bunch of demo programs that came with glut, and a bunch of other programs from miscellaneous sources.

It seems like only about 30% of them work at all. I’ve tried on different machines with different configurations, and still, I can only get about a third of them to run. I’ve tried with computers that have a 3dfx voodoo5, others that have an ELSA Gloria2, and a couple others; although a put most of the effort on the first 2 I mentioned.
Off course, I have the latest drivers for both the 3dfx card, and the Nvidia-based card. I tried on P3 733s, P3800, and AMD K6. With Intel motherboards, Asus motherboards, and some others. No difference.
Still, only a third of them run. Not the same 30% across the different machines thou. Some work on the 3dfx-based machine only, some on the Nvidia-based on, etc.
As a developer that is something that would make me shy away from opengl and into directX. 100% of the demo’s I got for directX worked.
I also had the problem were I would compile an opengl program that would work fine on the debugger, but if I try to run it outside the development application, it wouldn’t run.
Any ideas?