OpenGL problem with an Astronomy Program

The program is called Starry Night Pro. It uses OpenGL to render the graphics for a more realistic view. This is my problem:
I upgraded my hard drives to Serial ATA (because of an IDE drive failure, I wanted to change). With the exception with the hard drive, all other hardware and drivers are exactly the same in both instances - pre and post serial ATA. Since then, I have not been able to run this program.

I have tried all sorts of troubleshooting methods: limited start ups, driver changes to the video card, reinstallations, shifting PCI locations of the SATA card, all with no luck. I even tracked down an IDE drive and removed the SATA drives and cards with the same result - no ability to run this program.

When the program starts up a second time after a freeze, the program automatically turns off OpenGL, but the program still freezes. I have yet to actually run the program.

I downloaded some video benchmark software to run just to see if my video card is OK, and running the benchmark was no problem. I even ran the “dxdiag” to check my DirectX drivers and those were OK too.

I am at a loss. The folks at Starry Night software are stumped. I am concerned there may be a problem with my video card, but there is no way to know for sure unless I buy a new card - I do not want to do that yet unless I know for sure that my card is the problem.

Some questions:

  1. Is there a way to test OpenGL only?
  2. Is there a chance that during my driver downloads, the video card itself was somehow affected (the BIOS)?
  3. If so, is there a way to update the BIOS on the card?
  4. Are there any other very obscure troubleshooting tip I can try?

As an FYI - I do have the SandraSoft Suite of testing software, and every test I ran passes with flying colors. However, I believe SandraSoft has no way to test OpenGL.

My equipment:

  1. Asus P4T533-C mainboard
  2. PNY nVidia Quadro 750XL video
  3. Pentium 3.06GHz with H.T. enabled
  4. Dual Seagate SATA drives
  5. Adaptec 1210SA SATA card
  6. Soundblaster Augigy 2 Platinum sound card
  7. Samsung RDRAM - 1GB

Wrong place - sorry:

I tried a few other things with no luck:

  1. Reverted back to the nVideia 29.xx series drivers - no luck
  2. I put in a different video card, a GeForce 4, with the same results - nothing.

I think that rules out my video card. Could the motherboard be to blame?

I think it’s simpler to run something else that uses GL and see what happens, then to screw around with BIOS updates, and tinker with the hw.

If that doesn’t work try setting the AGP aperature to max, lower the speed, maybe turn off write combining.

What’s your OS?

Windows XP

I actually did all of that, and some. The OpenGL screen savers work fine, but I do not have any other OpenGL apps to test - none that I know of anyway; that is unless Age of Mythology uses OpenGL. If so, that works flawlessly.

With the changes with write combining and lowing the acceleration only made the freezing worse, meaning the program would not start at all. Right now, I can get as far as the program accessing the “panorama.” That is, a pretty green field panoramic image that uses OpenGL. The idea of the software is that if there is a problem with OpenGL, the software defaults to the non-openGL version. But that does not work in this case. I must stress that the program installed on another PC works just fine.

Thanks for the reply,