OpenGL not being recognized by Game

I have Nascar Racing 2002 by Papyrus. I just got a new GeForce4 Ti 4400 and the game won’t recognize OpenGL. Run adequately in D3D, but I would like to be able to at least compare and choose between the two.

I think my problem may be akin to someone’s in another thread. It recognizes my video card in OpenGL as being from Microsoft Corporation with a GDI Generic Renderer. It’s not recognizing Nvidia at all. Other people I know with this game have no problems with comparable systems to mine.

Anyone have any suggestions as to how I could fix this? When I try to reconfigure my graphics in OpenGL from the game or in Windows Explorer, the game locks up and I have to reboot. I have tried a couple of different sets of drivers to no avail. Currently running the 28.32’s.


[This message has been edited by BEB107000 (edited 05-16-2002).]

Did you uninstall the drivers for your old video card? It’s possible they could be lingering around mucking things up.

What OS are you running? Do you have DirectX8.1 installed?

I killed all the drivers for the old card (GeForce 2 Pro) prior to installing the new one. FWIW, OpenGL would not run with the old card either. Used to work great up until about two weeks ago. This is probably something pretty simple. OpenGL is just not being recognized.

I am running in Win ME.

Is there a link where I can download Open GL 1.2 or 1.3 and see if it will override what’s on my system?

Thats the point:

You cant d/l OpenGL.

Its part of your display drivers.

There is no such thing as an OpenGL download.

Never have, never will.

I have Nascar Racing 2002 Season also and when I try to start it up it says "you must first set your desktop to a hi color (16-bit)or true color (32-bit)color mode. I have tried to change the color modes in windows explorer and when I do i see the Open Gl logo down in the corner of the screen, and also i looked in the readme manual that came with the game and it says stuff about the open gl also…so thats what led me to think that it is an open gl program problem. Got any idea’s what is wrong??