opengl help

Ok. My system specs: AMD-K62 533MHz, 184MB SDRAM, ATI Radeon 32MB SDRAM PCI.

A while back I had messed up bad while installing new drivers on my system and ended up installing it halfway twice (Windows wouldn’t visually load, had to go through SafeMode)… I had to get it repaired and when I got it back, I no longer had opengl. Also, now whenever I take a screenshot theres like two desktops there. Half is my regular desktop, then on the other half, its this dark colored version of my wallpaper. Basically I was wondering if I could reinstall drivers to get it back. Or if that could end up bringing back my problem?

Is your system detecting the appropriate video card in the “Device Manager”? Right-click “My Computer”, select “Properties”, then “Device Manager”, make sure it sees the Radeon under “Display adapters”. Also, under the “Options” tab of your “Advanced Display Settings”, you should be able to determine the version of the driver you are currently running.

When installing new video drivers: make sure you uninstall the previous drivers, reboot, hit “Cancel” when Windows finds the videocard after restarting, and then load the new drivers.

Also make sure you have DirectX8.1 installed before loading the new drivers.

I am curious as to why you say you have “no opengl”? Are you having problems with any specific games, other than the screenshot issue?

Well, whenever I try to run a game in OpenGL, it says “Your video device does not support that type” or something like that. And with games that are based off the Quake 3 engine, it says “Could not load OpenGL” or whatever. And yeah, the video card is detected in the device manager and I’m running the 4.13.7115 driver for my Radeon. I was thinking of using the GLSetup program, but it had all that stuff in the disclaimer.

I wouldn’t use GLsetup, the correct driver from your video card manufacturer should be sufficient.

I suggest you follow my instructions above for un-installing the old drivers, rebooting, and loading the latest drivers from Ati:…R&cmdNext=GO%21

I assumed you used Win98, if you use another OS, download the correct version. And make sure you are running directx 8.1 (Click “Start” -> “Run”, then type in “dxdiag” without the quotes to determine Directx version).

Good luck, let us know if it works out.

Should something go wrong because of the past problem that I had to get fixed… how would I go about loading Windows in Safe Mode? I don’t remember which button you have to press to load it up but I remember when it wouldn’t visually load windows, it’d still load Safe Mode. Then there, could I just go to Settings>Control Panel>Add/Remove Programs and just remove the drivers?

Yeah, uninstalling from safe mode should work.

To enter safe mode in Win98, you can either hit the F8 key right before you see the “starting windows” splash screen, or else hold down the shift key while the machine is booting, and it should dump you straight to safemode.

Incidentally, please don’t take my advice unless you are comfortable performing the driver installation and removal, I’d hate it if something were to mess up, and I can’t be responsible if you break something.

Good luck!

i kind of got the same problem a while back i was playing the demo of AvP which had opengl support but when i tried to install Q3 demo it wouldn’t work so i thought i’ll play AvP and that wouldn’t work i can’t find any openGl folders or files in my system what happened

DirectX 8.1