OpenGL has just stopped working...

For some reason I can’t run anything that uses OpenGL anymore. It either gives me an error or runs extremely slow. It’s not my system because OpenGL used to work fine. Oddly though, DirectX still runs and works the way it should, even with hardware acceleration set. I didn’t make any changes to my video card (which is a NVIDIA GeForce 256 AGP) setup, but it happened one day when I tried to run a Half-Life game (which I do often) and it gave me an error saying I couldn’t support that mode. I’ve already tried installing new drivers (and reinstalling the old one), downloading and running glsetup.exe, and even reinstalling the runtime files (for OpenGL). I have no idea why this happened and any ideas on what to do would be greatly appreciated.

I have the exact same problem, and it happened the exact same way. I ran Half-Life one day and it said my video card didn’t support the requested mode blah blah. After trying several other games I finally came to the conclusion that OpenGL stopped working on my box. I’m running Win2k with a TNT2 M64 (PCI) if thats of any help. If there’s no fix I can just format and reinstall though, just wondered if I could avoid that.

  • thnx


It sounds like a typical DVA problem.
Check if your WIN.ini got a line called
DVA. If you got this line give a reply.
Or look in other posts in this forum

Yeah, I have the DVA line. It is as follows:


What should I do now?

I looked through all the other posts but none of the solutions helped me a bit.

I feel all your pain. I have been searching for a solution for this for a while…Here’s what my Q3 log looks like:

Q3 1.11 win-x86 Nov 24 1999
----- FS_Startup -----
Current search path:
F:\Quake3\baseq3\pak1.pk3 (7 files)
F:\Quake3\baseq3\pak0.pk3 (3539 files)

execing default.cfg
execing q3config.cfg
couldn’t exec autoexec.cfg
…detecting CPU, found Intel Pentium III

------- Input Initialization -------
Initializing DirectInput…
Couldn’t set DI coop level
Falling back to Win32 mouse support…
Joystick is not active.

----- Client Initialization -----
----- Initializing Renderer ----

----- Client Initialization Complete -----
— Common Initialization Complete —
Winsock Initialized
Opening IP socket: localhost:27960
Hostname: sowdog
Working directory: d:\q3
fs_cdpath is write protected.
----- R_Init -----
Initializing OpenGL subsystem
…initializing QGL
…calling LoadLibrary( ‘C:\WINNT\System32\opengl32.dll’ ): succeeded
…setting mode 3: 640 480 FS
…using desktop display depth of 32
…calling CDS: ok
…registered window class
…created window@0,0 (640x480)
Initializing OpenGL driver
…getting DC: succeeded
…GLW_ChoosePFD( 32, 24, 8 )
…41 PFDs found
…hardware acceleration found
…PIXELFORMAT 5 selected
…creating GL context: failed
…failed hard
…restoring display settings
…WARNING: could not set the given mode (3)
…setting mode 3: 640 480 FS
…using colorsbits of 16
…calling CDS: ok
…created window@0,0 (640x480)
Initializing OpenGL driver
----- CL_Shutdown -----
RE_Shutdown( 1 )
Shutting down OpenGL subsystem
…wglMakeCurrent( NULL, NULL ): failed
…releasing DC: failed
…destroying window
…resetting display
…shutting down QGL
…unloading OpenGL DLL

Q_strncpyz: NULL src

OpenGL has just completely stopped working. D3D works fine.

I checked the other posts. Apparently, you are supposed to find the DVA line and then put a semicolon ( in front of it. My line was:


Then I changed it to:


After doing that OpenGL began working again. I’m not exactly sure why it does that, but I suppose DVA stands for Direct Video Access. It’s probably 1 (or TRUE) by default, but some program changed the WIN.INI file to make it equal 0 (or FALSE). With DVA off, OpenGL probably can’t access the video card for hardware acceleration. It would probably also work if you change DVA=0 to DVA=1, but I haven’t tried it…

Hate to post so close together, but I just had to say this. I acted of my instincts and changed DVA=0 to DVA=1 instead of ;DVA=0. Just as I suspected, that solution works too.

Im sorry I didnt follow the post up.
I see you find the solution anyway.
Beware of this DVA problem can happen whenever. Next time you got two lines. one of them the one youve already editing the other you have to edit again.

Sorry, that i fetch up this thread again. i now have exactly the same problem (and this is the third(!) time on different systems). for some reason, i don’t have this “DVA” line in my win.ini. is there any other possibility why it couldn’t work, or may i just add this line with option set to 1?
as i have been working on this problem for 6 hours now, you maybe know, how i feel grr

ok, i’m to stupid…
as i remember there were enough guys who asked “what to do, if the line does not exist?” (incl. me)
my solution is: just add the line!
open win.ini -> goto [DrawDib] -> place the line DVA=1
that’s it.