OpenGL Gaming Problems

I’m having problems with OpenGL in my games.

While playing IL-2 1946, the main menu and the game itself is horribly laggy, I can barely move my mouse around. Yet, when I switch the video mode to DirectX, it works perfectly and when it’s on OpenGL it gets all laggy and choppy.

While trying to play Star Wars Jedi Knight Jedi Academy, I get a “GLW_StartOpenGL() - could not load OpenGL subsystem” error.

I’m currently running Windows XP, with a Geforce 8800 GTS 640 MB video card.

Update your drivers


My drivers are up-to-date. Running version 169.21. I even tried rolling back to an earlier version, but that didn’t work.

Well I am sorry, but those old game should work, and if you don’t install your drivers correctly you can have issues. Did you uninstall the older one first? You have the same Gfx card I have and I can tell you I don’t have any issues. Sorry I can’t be more help.

I recently just upgraded from a Geforce 7950 GT. I’ve uninstalled and reinstalled the video card drivers many times now, and it still won’t work.

Try following these steps.

Alright I tried that program. Uninstalled my drivers, rebooted, Ran Nasty File Remover and removed the only two files that were the same version as my driver, rebooted, installed the newest driver, rebooted, and still nothing.

Although, when I look for Nvidia files, there’s a bunch of files that are not the same version, yet there are a whole bunch of them. Too many to name, but I do have screenshots if you need. Also, I looked for ATI files as well (My mobo uses ATI intergrated graphics, which I used for a short period during my switch from 7950GT to 8800GTS). The file names are ativvaxx.dll- Radeon Video Acceleration Universal Driver, and ati2dvag.dll- Radeon Windowsnt Display Driver. I tried removing them, but they can’t be completely deleted.

Also I noticed in Device Manager that I have an SCSI/Raid Host Controller with a yellow exclamation mark, if that means anything. I’ve also been looking on other sites and it seems that a lot of people have been having this problem, but most with different games and most likely needing a different fix.

I bet this are the ATI drivers. You will have to remove them somehow. Reinstalling windows might help.

I tried removing those two ATI files with Nasty File Remover, but they would just reappear.

Alright guys, sorry to sort of waste your time, but I was getting a real headache with this problem. So, I said to hell with it and reformatted and reinstalled windows. Everything is fine now. I wish I could of figured out the problem for future reference if someone else had this problem.