OpenGL doesn't exist anymore!

My computer doesn’t recognize OpenGL anymore. Half-Life says “The selected OpenGL mode is not supported by your video card”. Tried Q3, can’t initialize OpenGL. Tried benchmark tools, same problem. The only way I’ve fixed it is by reinstalling the system. This not a solution.

I’m running Win2k SP4, DX9, on an AthlonXP, Leadtek nForce2 mobo, 512 DDR 400, nVidia GeForce4 Ti 4200 with the newest FX drivers (tried about 4 different driver packs, old and new Dets). I’ve had this problem once, reinstalled the OS, worked fine. Then, I installed Visual Studio 6 it didn’t work anymore. It might be that, or it might be just a coincidence.
Also, do you know a good OpenGL diag tool? Tried bringing GLview, but their FTP site is somehow down. Let’s try and figure this out together. Many will thank us.

Its possible that opengl32.dll wasnt right. When Visual Studio installs this library can produce errors like this…

Have you tried using an NON-FX driver?

I’m going to suggest trying 30.82 or 29.42

It appears older cards have problems with newer drivers and OpenGL.

Thanx guys, but I’ve just solved the problem. I found the solution in another thread.

Originally posted by tran:
well i’ve fixed the problem after many hours of frustration. It wasn’t even a driver problem in the end.
For those of you who have matlab 6.5 installed then opengl will cease to work. If you kill it in the task bar then games or anything using opengl will work again. I really don’t know why this is the case but it friggin got me out for at least sometime. Well now that its working i might go and complain to bloody matlab about their damn software which caused me hours of grief.
Hope this helps some of you people out their.

That was it! It was freakin’ Matlab 6.5! Didn’t work like tran said, I had to uninstall it, but OpenGL works now. I’m ready to join the tran fanclub!

Thanx guys for the effort! I hope this will help others too!