OpenGL does nothing. Apps load into memory and take full cpu, but don't load further.

OK, I allready submitted this problem to ATI and to the NeoAxis forum. ATI doesn’t give any response, the NeoAxis people don’t know how to fix it too except telling me to try XP. I run Vista (Ultimate-32bit) and a long time ago I did run Doom3 on vista. ATI also implemented OpenGL in their drivers for Vista, so it should work, right?
My PC has a 760MPX mobo, 2x XP2200+, 1GB Infineon ram and a HIS X850XT graphics card.

I was trying to get the NeoAxis engine running but it kept giving me errors. It got stuck when loading the OpenGL driver. However, the program did load into memory and took 50% of my dual-CPU. I have the engine running now by forcing it not to load OpenGL.

Now I’ve started testing what the problem was exactly and I noticed OpenGL won’t run anymore at all. Not in NeoAxis, not in Quake3, not even in NeHe examples. The problem is the same everywhere: it loads into memory, takes a lot cpu time and just stays sitting there until I force it to close through the task manager. Most examples I’ve tried don’t even display anything after loading, and if there is some screen, then it’s a not responding one. I guess the programs still load in the background or they hang quite good, cause there are no logs generated, no error messages, no feedback at all.

I just reinstalled my computer (windows vista ultimate, 32bit) and I did a reset of my bios (load failsafe). Still the same stuff: Direct3D works perfect, OpenGL does nothing.

There is a thread going on at the NeoAxis forum about my problem. Maybe it can give some more information. It also gives more detailed hardware information about my computer.

I hope to hear some kickass workaround or bugfix, cause I’m all out of ideas. Maybe someone can provide me a full debug OpenGL example so I can go checking logs and stuff…


Yow, just found out this is a driver issue.

I noticed PaintShop Pro (v.X) didn’t want to load either. By doing a Google search for “PaintShop crashes” I got this thread on a nVidia forum:

So, just switched back to ATI 7.1 and everything is back to normal. OpenGL and PSP are back on my desktop :slight_smile:

Apparently ATI is even more stupid than nVidia. Same bug as nVidia’s 81.xx drivers, only two years later.