No luck on a decent one year old PC

No rotating cubes for me yet…

Either using:

  • Minefield 3.7a1pre with “switch webgl.enabled_for_all_sites = true”
  • The latest Chrome launched with “–enable-webgl --no-sandbox”

Windows XP, 32-bit (SP3)
GeForce 9500 GT, version 177.92

Next step: trying to update the NVidia drivers?


Upgrading to the latest NVIDIA drivers didn’t help!

Important Update:

It seems that the problem is not on the drivers side…

In Minefield, I can see the following in the Error Console:

Canvas 3D: creating PBuffer...
Canvas 3D: ready
Error: CanvasFloatArray is not defined
Source File:
Line: 160

The WebGL example I’m looking at is this one:
The results are quite similar with the other examples from here:

Like if the version of Minefield (and apparently Chrome) that I’m using are too recent to be compatible (syntax-wise) with most of the WebGL examples published on the web…
Makes sense?

Another Update

Cube Defense does work.
Seems like it’s not based on the same js utils or libs than the examples I previously tested…

Hi arielm,

Thanks for the heads-up about that. The problem you’re seeing is because the WebGL API changed recently – a class called CanvasFloatArray was renamed WebGLFloatArray – and the stuff in my examples list pre-dates that change. I’ll update the list to point to newer examples.

The other stuff on my site (for example, and, as you have a good GPU, should all work, and you can will find a lot of interesting stuff in the lists of links I’ve posted (collected here: I particularly recommend



Thank you Giles,

Minefield seems to cope with the bouncing mandelbrot cubes.
But in the dancing solar-system example: no sun. Seems like a shader issue…

Note that I could not manage to get anything to work with Chrome yet (latest version, correct command-line parameters…)
Does it mean that most of the Windows developers rely on Minefield?

I’ve updated my “getting started” page to give links to demos that I’ve checked definitely work with the latest Minefield: (I’ve kept a list of older ones that no longer work, but with a note saying that they don’t.)

I think most people do rely on Minefield, but I’m a bit surprised nothing’s working for you with Chrome. I just checked with the dev channel version (currently version, and all of the links on my updated getting started page worked apart from Cube Defense (though there was no audio on the musical solar system). All of the lessons worked too.

Did you install Chrome using one of the methods on my “getting started” page, or from somewhere else?

Bingo, it’s now working!
I was running the “normal” Chrome (and I totally missed the “dev channel” part…)

Aha, that would do it :slight_smile:

Glad you’ve got it working now.