Intel/OpenGL/Savage

I have the Intel® 82815 Graphics Controller fully updated version.

I just bought the game Savage today.

When I went to run the game it told me I had an error with my OpenGL driver (Microsoft Corp. GDI Generic v1.1.0) whatever. So I updated the driver and that fixed that.

Then, I went to run it again, and it told me I had an error with my Intel Intel Solano v1.1.2 - Build 4.13.01.31** (whatever) and I needed OpenGL v1.2 to run the game.

I can’t find an upgrade for it anywhere!! Can anyone PLEASE PLEASE PLEASE tell me how to upgrade from version 1.1 to 1.2?

Or what the problem might be aside from that?

Please help…

SAVAGE: The Battle for Newerth

Minimum System Requirements:
Windows® 98, ME, 2000, XP or Linux
Controls: Mouse and Keyboard
CPU: 600 MHz processor
Memory: 128 MB RAM
Drives: 4x CD-ROM and 600 MB Hard Drive space for installation
Video: GeForce or Radeon series graphics cards
Online Connection: 56k modem

Recommended System Requirements:
Controls: 3 button mouse with a scroll wheel
CPU: 1000 MHz CPU or better (subject to change)
Memory: 256 MB RAM
Video: GeForce4 or better (or OpenGL compatible Video Adapter card with 64 MB RAM)
Online Connection: Broadband (Cable Modem, DSL, or better)

Originally posted by ReadThisPlease:
[b]I have the Intel® 82815 Graphics Controller fully updated version.

Or what the problem might be aside from that?

Please help… [/b]

Updating your drivers all day won’t help. You need a REAL video card.

Originally posted by Uh:
Updating your drivers all day won’t help. You need a REAL video card.

Recommended System Requirements <---- Did you notice that part?

Recommended…

And did you read the part about the minimum system requirements?

Video: GeForce or Radeon series graphics cards

Required…

Sorry but the integrated 3d Intel has to offer is a piece of crap (thats true for all integrated 3d chipset available). They are slower then the slowest AGP card.

The Solano (82815) is an very old chip to. I had one of those 2 or 3 years ago. I was barely able to play Q3A with it. To give you some numbers:

It had a pratical fillrate of around 50MP (Megapixel per second). Even my stone old Geforce1 did 175MP, the Geforce3 did around 500MP and a ATI 9700 Pro goes well beyound >1200MP.

Not to mention that the Solano only offers only a handfull of 3d features, while today cards have a countless amount of additional eyecandy (Bumpmapping, Cubemapping, T&L, Pixelshader, Vertexshader, 3d Textures, Stencilbuffers, P-Buffers, FSAA, Anisotropic filtering, and the list goes on).

The reason the Solano does not support OpenGL 1.2 is that it doesnt have the abilities that are required for OpenGL.

If your board was a AGP slot just buy a Geforce2MX for around 20$.

Originally posted by ReadThisPlease:
[b] Recommended System Requirements <---- Did you notice that part?

Recommended… [/b]

The reason I bolded recommended is because if you are buying a GeForce card, 95% of the time TODAY it will at least be a GeForce4.

Now a GeForce4 is about 8 TIMES as powerful as that POS Intel® 82815 integrated video controller you have in your computer. So, what I’m trying to tell you over and over is that you will NOT UNDER ANY CIRCUMSTANCES BE ABLE TO PLAY WITH YOUR CRAPPY INTEGRATED VIDEO. PERIOD. END OF STORY.

Well i just bought the game also …and i need to know where to get an updated version of OpenGL instead of version 1.1…i need like 1.2 at least…im running win xp and i got all the requirements