I fixed the "could not load OpenGL subsystem"

I been working on this problem all weekend and finally figured it out. I was getting the exact same message trying to run MOHAA. I have 3 different computers and 2 with WinXP one with WinME. It ran on one of the system with no problem (it was a WinXP P3 866 with a ATI Rage/Expert 2000 32 meg). I have another system with WinXP with a Nvidia TNT2 64m and it was working find then I upgrade it to a G-Force 2 MX 400 and got the error message “can not load opengl subsystem” try server of the mentioned problems (i.e. install the latest Nvidia driver 23.11 along with server older version 21.83 and serveral others, looked for the DVA=0 in win.ini which wasn’t there, drop the opengl32.dll into game dir and del 3dfx???.dll) none of these fixed the problem. So I switch out with one of my ATI cards and it still didn’t work. So I looked into the system that was working and found in the c:\windows\system32 a different opengl32.dll file on the problem machine, it was 2,680 K dated 12/10/2001 and the one on the working machine was 670k dated 8/23/2001. I copied it over and wall-la it worked. So, then I put my Gforce2 MX 400 back in and it still didn’t work. Then, I remember something from one of the post here saying to try the unreleased Nvidia beta drivers 27.20 uninstall current 23.11 and install 27.20 and now it works, hur-ray. Then on the Win ME system I put in the TNT2 M64 AGP card and it didn’t work with the default driver from WinME. I then installed the lastest/official release ver 23.11 on it and it ran like a charm.
Bottom line is that there is not a single solution, but here are the ones that worked for me. Hope this helps you.

  1. check the version of opengl.dll in your “c:\windows\system32” directory. maybe try different ones, but the one that worked for me was 670K dated 8/23/2001. (If you look up serveral lines on the error messages you will see which directory the OpenGl32.dll file is loading from, so you only need to change or work with that one)
  2. Make sure you have the latest Driver and in the case of Nvidia you might need to get the lastest beta version (ie. v27.20)from http://www.guru3d.com/files/
    I think this is the case with WinXP and newer Nvidia cards, cuz the 23.11 version for WinXP doesn’t seem to support opengl on some of the newer Nvidia cards.

Let me know if this helped. robcroft@cox.net