I was just playing Medal of Honor one day (it had been working so far)and all the sudden it crashed when i started it.

It had the message “failed to start Opengl subsystem” or something close. I tried everything:reinstalling, EA tech support,updating my graphics driver = nothing.

This has been going on for a year or two, i want to play it, help me pleese.

You mean “Allied Assault”?

I think you can copy and paste the log that appears on the startup window, post it here.

What graphics hardware do you have. What OS? Did you install any updates, patches, drivers or hardware recently?

Yes “Aillied assualt” and both expansions.

I have an Nvidia Geforce 2 card, and Windows xp home edition.

IF i did update anything i don’t remember (It has been down for years)

I am pretty good with computers, i’m just unfamiliar with this program

It worked before, and then just stoped.

LOG (bottom line flashing red):

Initializing OpenGL driver
…getting DC: succeeded
…GLW_ChoosePFD( 16, 16, 0 )
…23 PFDs found
…GLW_ChoosePFD failed
…GLW_ChoosePFD( 16, 16, 0 )
…23 PFDs found
…GLW_ChoosePFD failed
…failed to find an appropriate PIXELFORMAT
…restoring display settings
…WARNING: could not set the given mode (3)
…shutting down QGL
…unloading OpenGL DLL
…assuming ‘3dfxvgl’ is a standalone driver
…initializing QGL
…WARNING: missing Glide installation, assuming no 3Dfx available
…shutting down QGL
GLW_StartOpenGL() - could not load OpenGL subsystem

OH YEA! I recently updated my driver, but it did not fix anything (this was after the problem started).

Looks like a display problem. Maybe because the display resolution is no longer supported by the driver? Did you switch monitors perhaps?

There should be a number of config files in the game directory, I believe they have .cfg extension. You can try to replace the user/player cfg with the default cfg, then load the game and see if it works.
If you can find the display resolution in those files, modify it so it is the same as the windows desktop resolution (this worked for me on Call Of Duty, same Q3 engine).

That said, do other OpenGL programs/games work? Like Half-Life? I wouldn’t be surprised to see a Geforce 2 card fail these days, they’re pretty old. You’re not hearing a whining noise from the GPU cooling fan?

I’ll try it, I did not switch monitors or drivers BEFORE this happened.

Do you know the excact file name or folder, becase my directory is not in its own folder. (its in my general game folder, oops)
(that can’t be the problem ether, it was placed there after the problem).

I don’t have the game installed on my machine anymore so I’m not sure what the exact filenames are. I think the config file is “unnamedsoldier.cfg”. But if you re-installed the game with default settings it should be ok.

You can try to revert to an older driver version. Or maybe the card is bust. An upgrade be wise anyway if it’s a GeForce2.

Also, Google is your friend. Ask on some MOHAA discussion boards…

Good luck.

Hi, well i fixed the problem my self by accident wile trying to do it your way, lol, ackward.

Thank you for you help anyway!

… Google is not my friend: The have signed a contract with the comunist chineese government to Cencor half of the internet for chineese citizens. It was all over the news last year.