GL-Extensions are causing a bug


I have a Kyro2, and in most of my OpenGL-Games it seems as if the Vertical Sync was deactivated. But I have not deactived it anywhere. Then, when I deactivate the GL Extensions, this bug(?) disappears.
Some of the games with this issue:
FAKK2, SeriousSam, Alice, Tribes2, Quake1-3, Halflife(I was able to correct the issue in this game with typing gl_d3dflip in the console, so now it works in D3D).

Now I just want to know which of the Extension can cause a bug like this?

I think that you have a OpenGL extension for controlling vsync from the program. Games that alters the vsync behaviour should let you decide if you want that feature.

Search the programmers forum if you want the exact name of the extension. It should be a wgl extension and it will not work on all Windows versions.

The Name of the extension is:
“WGL_EXT_SwapControl”(I found it out on my own). OK, in games with Quake Engine, In now can correct this by typing “r_SwapControl 1”. It is always set to “0” when I start an OpenGL Game. --> Problem solved for Quake-Engine-Games. But what to do with the other OGL-Games?