Getting an error code of -1001

Hello OpenCL programmers,
I am using Visual Studio 2010 for coding in OpenCL. When I run the following program, I am getting an error code of -1001 and no. of platforms as 0. I have installed AMD APP SDK 2.9 in my system. I have an Intel Dual Core CPU but no GPU.

#include “CL/cl.h”
#include <stdio.h>

int main()
cl_platform_id pid;
cl_uint num;
cl_uint n=1;
cl_int error=clGetPlatformIDs(1,&pid,&num);
printf(“Error code= %d
No. of platforms= %d”,error,num);

Please help. Thanks in advance.

You have to install an OpenCL driver for a supported device. Since you have an Intel CPU but no GPU, you should install the Intel OpenCL driver instead.

It worked. Thanks a lot. I was stuck there for a long time.

I have an identical error code with a different OS and set of hardware. I do not know if that constitutes a different thread.
I have an Nvidia GPU and an AMD 8 core CPU. running on Debian AMD-64. nvidia.icd is located in /etc/OpenCL/vendors
OpenGL has been running successfully on this machine, but I have not gotten past “Hello World” in OpenCL.