eVGA cards won't run OpenGL apps with HW accel. (for me)

Very strange problem. I’ve been over this with eVGA and nVidia for months. I had been happily running my 1.2 GHz AMD-based system for a couple of years with an Inno3D GeForce2 MX400 card. Very nice performance for both DirectX and OpenGL apps. As a developer who works with FlightGear, I wanted to have better performance, however, so I bought an eVGA 6800 card. It seemed to install fine and ran very well. Except, I found that it would not run any OpenGL applications unless I disabled all hardware acceleration. I contacted eVGA, uninstalled and reinstalled various flavors of drivers. Nothing worked. I placed my old card back in the machine. It still worked, and I ran OpenGL apps with HW acceleration turned on. I took the card out and replaced it with the new one (the eVGA 6800) again. No joy. eVGA replaced the card first with an identical card, then with an upgraded card. Same problem each time. I tried running a simple OpenGL test application that is bundled with FlightGear, I tried running Realtech VR’s OpenGL Extension Viewer, Stellarium, BilliardGL, FlightGear, Moray, etc. All of these applications failed in the exact same way:

Here’s an example of the Error Report Contents that gets sent to Microsoft (only the AppName ever changes):

AppName: billardgl.exe AppVer: ModName: nvoglnt.dll
ModVer: Offset: 0007d5df

Exception Information
Code: 0x000001d Flags: 0x00000000
Record: 0x0000000000000000 Address: 0x000000006957d5df

If I use the gdb debugger with gl-info (FlightGear-bundled app), I get this:

Starting program: /cygdrive/d/jon/src/flightgear/source/tests/gl-info.exe

Program received signal SIGILL, Illegal instruction.
0x6957d5df in gluPickMatrix ()
(gdb) where
#0 0x6957d5df in gluPickMatrix ()
#1 0x00006cd8 in ?? ()
#2 0x0177b8a8 in ?? ()
#3 0x6971b278 in nvoglnt!DllMain ()
#4 0x016b1a80 in ?? ()
#5 0x01222180 in ?? ()
#6 0x0177b8a8 in ?? ()
#7 0x01760480 in ?? ()
#8 0x01682200 in ?? ()
#9 0x016b1bac in ?? ()
#10 0x00000000 in ?? () from

I’m running WindowsXP with all the latest updates. If anyone can suggest any approaches I might try (that I haven’t already tried umpteen times!) I’d be very grateful. This has been extremely frustrating.

Best regards,

Jon Berndt

It could be a case that the origional driver is not being uninstalled correctly. You may have to either re-install windows or dig through the registery to find what the filename of the opengl driver is, then delete it and re-install the drivers.

I assume you get your video cards driver from the Nvidia site?

Yes, the drivers are from the nVidia site. When uninstalling the drivers, I also used Driver Cleaner, which was recommended to me by eVGA.

When you say “original driver”, are you referring to the nvoglnt.dll file? What’s confusing to me is, if nVidia has “unified drivers”, what’s different about one video card from another as far as the nVidia drivers are concerned?

Yeah I was mostly talking about the nvoglnt.dll file, but I see from the crash report that it is accessing the 91.33 nvidia drivers. I was thinking that the “origional” Inno3D drivers were some customized drivers that came with the card (as some companies did) and they are messing with windows in some weird way by forcing some weird registery thing when new drivers are installed.

The other thing is it could be a bug in the Nvidia drivers running on an older CPU/chipset. (I remember a bug ages ago that involved drivers using some SSE instructions even when the CPU did not support them - This is probably highly unlikely however)

If I was in your shoes, I would hook up a second hard-drive as the primary, install windows on that and if you get hardware acceleration on that, you know that it is a software config problem. (and you will need to re-install windows on your main drive) Otherwise, it is probably a hardware fault somewhere and I would see if it works in a friend’s PC.

If D3D was not working I would probably look at the AGP settings in the bios settings - perhaps disabling any of the AGP “fast writes” type of options?