Double sided texture not work

#1

Hi everyone. Sorry for my bad English. I create dae file to export to the web app. My surface has texture only on back (one side of surface). I want it has face and back texture. In collada spec 1.5 (page 26) i see that we should apply semantic attribute with double sided:
<input semantic=“POSITION” source="#grid-Position"/>
<newparam sid=“blah”>
<semantic>DOUBLE_SIDED</semantic>
<float>1.0</float>
</newparam>

But when i do this nothing changed. I paste this code:

<effect name=“Material0-fx” id=“Material0-fx”>
<profile_COMMON>
<newparam sid=“Image-Material0-surface”>
<surface type=“2D”>
<init_from>Image-Material0</init_from>
<format>A8R8G8B8</format>
</surface>
</newparam>
<newparam>
<semantic>DOUBLE_SIDED</semantic>
</newparam>

<technique id=“Material0-fx-COMMON” sid=“COMMON”>
<phong>
<ambient>
<color>1 1 1 1</color>
</ambient>
<diffuse>
<texture texture=“Image-Material0-sampler” texcoord=“CHANNEL1” />
</diffuse>
<specular>
<color>0.00784313725490196 0.00784313725490196 0.00784313725490196 1</color>
</specular>
<shininess>
<float>0.3125</float>
</shininess>
<transparency>
<float>0</float>
</transparency>
</phong>
</technique>
</profile_COMMON>
</effect>

What is wrong in my code that texture applied only for back of surface?

#2

I have the same problem :frowning:

#3

I think there is a very recent topic here about this exact thing… maybe PhantomPlum’s.

My advice is to use <bool> for this semantic. I think the manual’s example is a bad copy/paste job. That said, if you set it up correctly, like every other “param” then, it is just that your software is not implementing the feature.

EDITED: Notice your code doesn’t have the value. It looks like that is a required field.