DirectX works, but OpenGL doesn't,, Why?

I use several CAD programs, a couple of them have an option to run on DirectX or OpenGL, with the DirectX option they work fine but on OpenGL they don’t, they run very slow or not at all. One of my CAD programs, only has a OpenGL option, I can’t run it on DirectX.

Can anyone tell me what may be the problem?

The problem is that Microsoft doesnt like technologies that compete against their (propritory) technology.

This is especially true for OpenGL vs. DirectX.

As a result:

a.) the drivers that ship with Windows do not support OpenGL at all.

b.) you need to use the extension mechanism to access OpenGL 1.2 (and up) core functions under Windows.

In your case its most likely that you use the display drivers that came with Windows, head over to the website of your 3d card manufacturer and download the appropriate display drivers (those should support OpenGL).

If you already use the manfacturer display driver, you need to provide some more details about your system.

Thanks Querty,

I suspected the problem might be related to a conflict between DirectX and OpenGL, but neither Microsoft Support nor eVGA could give me an answer as to what might be the problem.

I have the latest driver for my display card, a GeForce 6800GT, I tried rolling back the driver to an early version, but still no help, so I don’t think the driver is the issue.

Here is my system info.

General Information

Product name Intel® Desktop Board D875PBZ based system
Board model Genuine Intel® D875PBZ system board
OS version Windows* XP version 5.1 Service Pack 2 build 2600
OS memory 1,570,536 KB RAM


Processor Intel® Pentium® 4 CPU 3.00GHz
Bus speed 800 MHz
L1 cache Data Cache 8KB, Execution Trace Cache 12K Micro-ops
L2 cache Advanced Transfer Cache 512 KB
Form factor Socket 478
Stepping 9


Physical memory 1,536 MB RAM
Memory speed DDR400
Memory type DDR, Synchronous
Form factor DIMM
BIOS date 03/31/2005
BIOS size 1024 KB
BIOS version P34 (BZ87510A.86A.0125.P34.0503312215)

I solved my problem with OpenGL!

I went into the motherboard Bios and restored the optimal defaults, saved changes and exited, I don’t know what settings were wrong but it solved the problem all my OpenGL programs are now working!